Trouble creating C# program on network for everyone RRS feed

  • Question

  • Im having real trouble in the 'publish' stage of my C# program.  Im fairly new to all this!

    I have published the program to a network drive (lets call it H:) which all works fine and there is a setup.exe file created.  I can install this no problems and have created Visual Basci programs like this in the past.

    The software is signed and works fine on my PC.

    The problem comes when colleagues of mine (about 40) want to install it as well.  When they click on the setup.exe, they are greeted with the message below.  When selecting details, there are a number of lines but the one that sticks out is

    "+ This program is blocked by group policy. For more information, contact your system administrator. (Exception from HRESULT: 0x800704EC)"

    Ive tried every combination of publish settings but have come up with nothing.  IS there any advice?!

    Monday, November 23, 2020 1:31 PM

All replies

  • Hello,

    The solution is as stated in the message provided.

    > This program is blocked by group policy. For more information, contact your system administrator.

    There happens to be a group policy that prevents the install, usually in active directory as is in may organizations, mine included.

    > The software is signed and works fine on my PC.

    This may be so but usually admins want

    1. VeriSign signing (or equivalent) not a free certificate
    2. Review the setup and application before moving to
    3. Unblocking the setup and application. 

    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    My GitHub code samples
    GitHub page

    • Proposed as answer by KHURRAM RAHIM Sunday, December 13, 2020 11:25 AM
    Monday, November 23, 2020 3:25 PM
  • Some more digging has come across this problem:


    IT are looking into it but are puzzled.  Something appears to be resetting the permissions (windows update / antivirus etc)

    Thursday, November 26, 2020 8:33 AM
  • Hi Mister S,

    Just ask if there is any progress.

    If the problem is solved, you can post the solution yourself and mark it as an answer, so that it will help other members to find the solution quickly if they face a similar issue. If you still have questions, please feel free to ask.

    Best Regards,


    "Visual C#" forum will be migrating to a new home on Microsoft Q&A ! We invite you to post new questions in the "Developing Universal Windows apps" forum’s new home on Microsoft Q&A ! For more information, please refer to the sticky post.

    Friday, December 11, 2020 2:55 AM