locked
TF86001: Team Foundation was unable to load the Office AddIn RRS feed

  • Question

  • After dealing with the daunting install process and getting it right, now I'm able to create projects and work with most of the items, however I found a new issue while trying to open any of the Excel sheets included in the default project team solution structure from WSS and I get that error, funny thing is that this only happens with XL files, since I can open Word and Project files with no issues


    Here's what I'm running on:

    Server: Windows Server 2003 sp1, SQL 2005 Sep CTP (data, analysis and reporting services), VSTS Server Foundation beta3, WSS sp2

    Client: Windows Server 2003 sp1, Office 2003 Pro sp2, VS2005 Release Candidate, VS Team Explorer, SQL 2005 Sep CTP (data services only)


    Any help will be greatly appreciated
    Friday, October 14, 2005 7:07 PM

Answers

  • Hi, 

    If you repair Visual Studio Tools for Office Runtime From the add remove programs in the conrol panel will fix the problem. 100% sure


    Thanks
    Friday, October 14, 2005 7:37 PM

All replies

  • Repairing visual studio tools for office should fix the problem. I think you installed office 2003 after VS Team Explorer.



    Friday, October 14, 2005 7:25 PM
  • thx for your reply
    this is my install order in the client:

    1. Windows Server 2003 sp1
    2. SQL Server 2005 Sep CTP
    3. Visual Studio 2005 RC
    4. Office 2003 sp2
    5. Visual Studio Team Explorer

    should I reinstall Visual Studio 2005 RC (which is the one that installs vs tools for office)?

    thx again
    Friday, October 14, 2005 7:29 PM
  • Hi, 

    If you repair Visual Studio Tools for Office Runtime From the add remove programs in the conrol panel will fix the problem. 100% sure


    Thanks
    Friday, October 14, 2005 7:37 PM
  • Hi!

    I'm experiencing the same problem.

    When I try to start a new list from within MS Excel, I get the error “TF86001: Team Foundation was unable to load the Office AddIn. This may be caused by a Team Foundation Client installation problem, or lack of .NET Programmability Support in the Office Application....”

     

    When it try to open a Work Item list from the Project Explorer within Visual Studio (for example: All TasksàOpen in Microsoft Excel) I get a different error: “TF80042: This document cannot be opened because you do not have Microsoft Excel (version 11.0) or one of its components installed....”

     

    I am running MS Excel 2003 (11.6560.6568) SP2, from the MS Office Professional Edition 2003 suite (English). All updates for Office products have recently been installed. Proofing tools from the German edition have been additionally installed.

    I first tried to repair “Visual Studio Tools for Office Runtime” from the Add and Remove programs, but it did not help. Then I uninstalled “Visual Studio Tools for Office Runtime” and reinstalled the complete “Team Foundation Client”, but neither that helped.

     

    Any help will be greatly appreciated J

    Tuesday, October 18, 2005 10:25 AM
  • Hi!

    Both problems were solved by installing ".NET Programmability Support" for Excel from the Office Setup....
    • Proposed as answer by TheOutlander Tuesday, January 18, 2011 8:47 PM
    Tuesday, October 18, 2005 2:58 PM
  • Repairing visual studio tools for office should fix the problem, I had the same problem.
    Tuesday, February 28, 2006 9:16 PM
  • I repaired Visual Studio for Office and I still get TF80042 errors when I try to open a Team Query with Excel.

    Any other suggestions?
    Thursday, March 2, 2006 6:56 PM
  • Verify that you have the following

    1. Excel 2003

    2. PIA's intalled (.Net Programmability support) as part of Excel

    If every thing is good.

    If you have .Net 1.1 or previous versions installed, and if you don't need it, try un-installing them, below is the list of candidates to consider

    1 - Microsoft .NET Framework 1.1

    2 - Microsoft .NET Framework 1.1 Service Pack 1 (KB867460)

    3 - Microsoft .NET Framework SDK (English) 1.1

    4 - Microsoft .NET Compact Framework 1.0 SP3 Developer

    Then please re-pair "Microsoft Visual Studio 2005 Tools for Office Runtime" from your Control Panel -> Add/Remove Programs

     

    Thursday, March 2, 2006 8:24 PM
  • Got it working, Thanks!
    Thursday, March 2, 2006 8:26 PM
  • Verified everything from your message, still have the same problem.

     

    Asif Khan

    Friday, March 3, 2006 2:24 PM
  • If the problem occurs in :

    Excel 2003 --> you have to repair "Visual Studio Tools for Office Runtime"

    Project 2003 --> you have to install/repair ".NET Programmability Support" in Project

    For me It works on several computers.

    Friday, October 6, 2006 2:08 PM
  • Hi Everybody,

    I would like to convey my experience over this:

    Long term back i have installed Team Explorer RTM version in my machine and keep on working over the same and after few months later i had requirement to work with MS Project 2003 more like customization....and I have installed the client version of MS Project 2003 in my system...

    Please note that, I have installed Team explorer first and then installed MS project 2003...but upto my knowledge it is not created any problem while installing aslo and i am working on the same without any issues in Office runtime plugins...

    So, i could clearly define that it is not the problem in installing team explorer after MS project 2003 or before that......please check out....

    Regards,

    Kathir

    Thursday, November 16, 2006 10:58 AM
  • your 100% confidence was well placed - that worked for me thanks.
    Thursday, March 1, 2007 4:14 PM
  • I have been unable to solve this, after:

    1. Reinstalling Office Professional 2003 (with full installs - to get the .NET Programmability Support).
    2. Repairing the Visual Studio 2005 Office Runtime
    3. Installing VS 2005 and TFS SP1
    4. reviewing install logs from a computer it works on, and a computer it doesn't
    5. Meticulously cross-referencing the registry entries to ensure all files are there
    6. manuall reregistering several DLLs in the Program Files \Visual Studio 8\Common7\ID\PrivateAssemblies and \Team Explorer directories (the ones related to Excel).

    Anyone have any suggestions?

    Wednesday, June 13, 2007 6:57 PM
  • I have the same problem.  I have tried all the fixes that have been proposed to no avail.  This issue was one of the reasons that I had my desktop re-imaged with XP Pro, including a new profile etc.  One of my tasks is to migrate defect tracking data from another product to Team Foundation and to do this I need all of the Excel/TF functionality working.

     

    My Office integration works fine with MS Project 2003 Pro but my problem is with Excel.  I can open Excel and import/export to/from TF but I can not open in Excel from TF without getting the error message TF80012.

     

    I have repair installed Office 2003 Pro, uninstalled/reinstalled VS 2005 Team Edition for Developers, VS2005...,SP1, Team Explorer.  I have applied all of the fixes/uninstalled old .NET frameworks, repaired Tools for Office Runtime..etc, listed in the forums.

     

    Is there a fix?????   I would appreciate any assistance.

    TIA

    Friday, July 6, 2007 3:29 PM
  • ClaireS, All:

     

    Please see the following post.  This fixed everything for me:

     

    http://forums.microsoft.com/MSDN/showpost.aspx?postid=1732864&siteid=1

     

    Hopefully this helps everyone with this problem - I would have liked to have seen more info on this in say, perhaps, the release notes from MS...

     

    Sincerely,

    rockman88

     

    Thursday, July 12, 2007 12:56 PM
  • Hi

    If you repair MS Office 2007 From the add remove programs in the conrol panel will fix the problem.

    100% sure

    1. Lookup your Office installation in "Add/Remove Programs" from the control panel.

    2. Click "Change"

    3. Select "Add/Remove Features" and click "Next"

    4. Navigate the feature tree for "Microsoft Office Excel" and ".Net Programmability Support"

    image

    5. Click the item drop-down and select "Run from my computer" and click "Next"

    6. Let Office do its configuration dance.

    7. Restart Visual Studio.

     

     

    • Proposed as answer by markmtal Friday, June 25, 2010 4:04 PM
    Thursday, May 6, 2010 9:42 AM