none
VSFlexGrid not Working on Windows 7 but works fine with XP RRS feed

  • Question

  • Hi everyone, 

    Platforms used

    • Windows 7 (32 bit)
    • VS2010
    • VB.NET
    • .NET FRAMEWORK 4

    We have an inhouse project that uses VSFLEXGRID.

    AxInterop.vsflex7 was added to the reference of the project

     I already registedered the ocx file using administrator rights in cmd - regsvr32 VsFlex7.ocx. The file Vsflex7,ocx is located in my C:\Windows\System32\ . I got the message "Dllregisterserver in Vsflex7.ocx succeded".

    When I compiled and run the solution and produced exe , the module with vsflex7 works on Windows XP  but does not work on Windows 7. I am using 32 bit.

    When I open Visual studio in XP  to review the code , works fine  but in Wndows 7, VS2010 automatically closed

    Both version of VS2010 was installed in XP and windows 7.

    I have read some threads and forums, tried it and tested , no luck. 

    I  have been reading now about DEP ...but I cant get it to work.. I'm stuck...can anyone help me ? 


    Saturday, January 17, 2015 3:09 AM

Answers

All replies

  • We have an inhouse project that uses VSFLEXGRID.

    Do you mean this product?
    http://www.componentone.com/SuperProducts/VSFlexGridPro/

    The best place to look for information about compatibility of that product with different versions of Windows would be the manufacturer. For instance:
    http://our.componentone.com/groups/topic/problem-registering-32-bit-ocxs-in-windows-7/

    • Edited by Acamar Saturday, January 17, 2015 3:18 AM
    • Proposed as answer by Cor Ligthert Saturday, January 17, 2015 7:31 AM
    • Marked as answer by Carl CaiModerator Tuesday, January 27, 2015 2:56 AM
    Saturday, January 17, 2015 3:17 AM
  • "When I open Visual studio in XP  to review the code , works fine  but in Wndows 7, VS2010 automatically closed"

    Does VS 2010 work on the Windows 7 machine? If you open another project in VS 2010 on the Windows 7 machine what happens? If you create another project on the Win 7 machine in VS 2010 does that work?

    If you open VS 2010 on the Win 7 machine and start a new program is the active x control available anywhere in the toolbox or in Choose Toolbox items? If not then perhaps if you get that working you may no longer have an issue attempting to open an application which has an Active x control in the designer window of a Form.

    However it seems to me the app should open anyhow and if you attempt to display the Form that the active x control is on there will be information about designer loss or something and the Form will not be displayed.


    La vida loca

    Saturday, January 17, 2015 5:08 AM