none
Set command line arguments when debugging exe - recent change in VS 2019? RRS feed

  • Question

  • I'm not sure if this is a change/regression in one of the recent updates to Visual Studio 2019 or a configuration issue on my machine.  I'm on Visual Studio 2019 16.2.3.

    I sometimes need to start an executable (for which I don't have source code) in the debugger.  I typically open Visual Studio and choose File | Open | Project/Solution... and browse to the executable.  Then in Solution Explorer I right-click the executable and select properties, and I'm able to set the working directory and arguments for launching the process.

    However when I right-click the executable and choose Properties, I now see a mostly empty screen.  I'm pretty sure I was able to do this successfully in the past few weeks in an older release of Visual Studio 2019.  Was there a recent change that moved these settings?

    I attached a screenshot showing the page I'm talking about in Visual Studio 2015 and the unexpected page I'm seeing in Visual Studio 2019 16.2.3.

    Tuesday, August 20, 2019 7:03 PM

Answers

  • Hi RobinsonWM,

    According to your description, please try to follow these steps:

     1. open vs -->select menu"Tools"-->Options-->Environment-->General-->uncheck the checkbox Optimize rendering for screens with different pixel densities..

     2. close the vs and reopen is and then open your project to check whether the issue persists.

     

    If it does not work ,try to  update your system and then try again

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by RobinsonWM Tuesday, August 27, 2019 6:56 PM
    Tuesday, August 27, 2019 8:38 AM

All replies

  • Looks more like a bug
    https://developercommunity.visualstudio.com/content/problem/679668/empty-properties-windows-for-external-executables.html
    unfortunately that thread seems a little stuck ... ( … notice the different Versions 16.2.1 -> 16.2.3 )

    With kind regards 
    Tuesday, August 20, 2019 9:18 PM
  • Hi RobinsonWM,

    Welcome to MSDN forum.

    I have tried to follow your steps, but it could work with VS2019 16.2.3, and my system version is Win10 1903

    Please try to open other external executables with VS2019 16.2.3, then check if it could work. And please update your system version to 1903.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, August 21, 2019 6:04 AM
  • Hi RobinsonWM,

    According to your description, please try to follow these steps:

     1. open vs -->select menu"Tools"-->Options-->Environment-->General-->uncheck the checkbox Optimize rendering for screens with different pixel densities..

     2. close the vs and reopen is and then open your project to check whether the issue persists.

     

    If it does not work ,try to  update your system and then try again

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by RobinsonWM Tuesday, August 27, 2019 6:56 PM
    Tuesday, August 27, 2019 8:38 AM
  • That workaround worked, thanks!  From the link above, it looks like it was indeed a regression and a fix is on the way. https://developercommunity.visualstudio.com/content/problem/683686/cannot-set-properties-for-debugging-standalone-exe.html
    Tuesday, August 27, 2019 6:57 PM