Unable to register Visual Studio 2013 Express Preview RRS feed

  • Question

  • Hello,

    Two weeks ago, I downloaded and installed "Visual Studio Express 2013 for Windows Desktop" from microsoft.com/visualstudio/fra/2013-downloads on Windows 7.

    On the first launch, I chose to skip the registration process.
    But now my 14 days preliminary license has expired, and I have troubles registering.

    When I start Visual Studio, a popup tells me to "connect to Visual Studio" in order to continue using Visual Studio. So I click on the "log in" button on the left of the popup, enter my login/password, and submit.

    After doing so, the "log in" button has been replaced by my personnal informations (so I'm sure that I'm actually connected), but nothing more happens. The text saying that I have to connect is still there and I can't do anything except log out or quit Visual Studio. There is no error message whatsoever.

    Friday, July 12, 2013 10:37 AM


  • Hi Tomaka,

    The VS team just marked this as being fixed. You should be able to extend the license irrespective of your current timezone settings now.


    Ed Dore

    Wednesday, July 17, 2013 9:06 PM

All replies

  • I tried uninstalling and reinstalling VS, but it didn't work. While writing this post, I'm currently installing the ultimate edition, just in case my bug is only in the Express edition.

    Just to show you a screenshot of my issue: uppix.net/xyrXa9.png (I can't post any image or link) (the screenshot is in french, sorry)

    As you can see on the left of the popup and on the top-right hand corner, I'm logged in. However on the right part of the popup, the text tells me that my license has expired, and that I need to "connect to Visual Studio".

    I can't do anything except log out or open a web page with my team foundation profile. If I close the popup, Visual Studio immediately closes.

    Friday, July 12, 2013 6:48 PM
  • I have the same problem. I gave up and installed 2012 :(
    Friday, July 12, 2013 10:39 PM
  • I have the exact same Problem. I actually suspected that I might be overlooking something obvious, but after hours of searching the web I still haven't found a solution.

    Is this a bug or are we missing something?

    Saturday, July 13, 2013 9:57 PM
  • Same here, Visual Studio 2013 for web preview on Windows 8.1 preview. I can't use VS anymore after 14 days from install.
    Sunday, July 14, 2013 8:14 AM
  • I have the same problem :-(
    Monday, July 15, 2013 12:28 AM
  • Monday, July 15, 2013 9:46 AM
  • Same problem here, German Version

    But I gave immediate Feedback through VS Express and got an answer this morning with a WORKAROUND !! :


    Hello. I’m responding from Microsoft to feedback you sent about Visual Studio:
    Date: 2013-07-13T16:43:51
    How the hell can I register my VS Express 2013 Preview for Windows ?
    Have you tried signing in to Visual Studio Express for Windows? If so and you are getting an error, could you try setting your time zone to Pacific time (PDT) and try signing in again? That may work around the issue.
    Michael Maio
    Visual Studio Test Team


    and it works !.

    Setting system time to Pacific Time ( UTC - 8:00 ) lets VS Express 2013 show up licensed to my ID, expiring in 182 days ( which is Jan 15, 2014 ) and with VS Express working.

    But when setting back system time to Central European, it's gone again. So it's really just a workaround to continue working on my projects.

    I crosspost this in the other thread mentioned here.

    • Edited by mhoffmann Wednesday, July 17, 2013 7:57 AM error correction
    Wednesday, July 17, 2013 7:56 AM
  • Hi Tomaka,

    The VS team just marked this as being fixed. You should be able to extend the license irrespective of your current timezone settings now.


    Ed Dore

    Wednesday, July 17, 2013 9:06 PM
  • Mine is still not working.. :(

    Any resolution?

    Friday, July 19, 2013 12:53 PM
  • November 29th and it's still not working. Setting Pacific timezone works but thats not where I live...
    Friday, November 29, 2013 10:41 PM
  • I got the following error when trying to login

    Impossibile trovare il metodo 'Void Newtonsoft.Json.Serialization.JsonDictionaryContract.set_PropertyNameResolver(System.Func`2<System.String,System.String>)'.

    no workaround found up to now....any suggestion?

    Friday, December 20, 2013 6:52 PM
  • I have same problem, How can I fix it?
    Monday, January 27, 2014 9:53 AM