.NET Framework setup failed with 0x8000247


  • Today i installed the sims medieval on my laptop. A few months ago my laptop crashed and i got a whole new hard drive. Before i could run the sims medieval, but now it won't install Framework 4.0. I allready cleared all my previous versions and cleared my %temp% directory. Also i tried to run the installation with windows updates enabled and without them enabled. I don't know what to do anymore.
    Sunday, March 25, 2012 11:45 AM


All replies

  • Hi Erika,

    We will need to see your full install logs. Supply your logs as follows:

    Please collect your install logs with this:

    After you run Collect.exe, you'll find in your %temp% directory. Please upload to a public site, like SkyDrive, and post the link here.



    Sunday, March 25, 2012 1:49 PM
  • Hi,

    I made the logs and uploaded them ;)!136&parid=3E40B73D038A6CE1!126&authkey=!ALnrhzUuMbJ8eMs

    Sunday, March 25, 2012 3:01 PM
  • Hi Erika,

    Welcome to the MSDN forum.

    From your logs:

    [3/25/2012, 16:47:34]Exe (C:\Users\Erika\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu) failed with 0xc8000247 - (null).
    [3/25/2012, 16:47:34]PerformOperation on exe returned exit code 3355443783 (translates to HRESULT = 0xc8000247)

    The error code “0xc8000247” means “The Unicode character is not defined in the Unicode character set installed on the system.”. Please ensure you download the corresponding language version of .NET Framework.

    First, I found you installed .NET Framework 4 via a web installer, so I recommend you download the standalone version:

    Second, check if there are any anti-virus or antispyware applications running. Make sure they are turned off during installation.

    Third, complete or dismiss Windows Updates before installation (but turn on Windows Update service).

    Then, clean up your “%temp%” folder (Start>>Run>>%temp%)

    Finally, run the setup file with Administrator privileges: Right-click the installer > Run as administrator.

    In addition, please ensure all .NET Framework 3.5 SP1 features are enabled. To do so: Start>>Control Panel>>Uninstall a program>>Turn Windows features on or off>>Ensure “Microsoft .NET Framework 3.5.1” and all its sub nodes are enabled.

    If you have any other problems, please feel free to let me know.

    Best Regards,

    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    Monday, March 26, 2012 5:30 AM
  • Hi

    Thanks for your reply, i tried it but i still get the same error. Here are the new logs:!137&parid=3E40B73D038A6CE1!126&authkey=!AEVDPTtnLf68iFw


    Monday, March 26, 2012 9:54 AM
  • Also I installed in january the latest version of Microsoft Silverlight, maybe that has something to do with it?
    Monday, March 26, 2012 9:56 AM
  • Hi Erika,

    From your log:

    [3/26/2012, 11:36:45]OpenService returned: The specified service does not exist as an installed service.

    [3/26/2012, 11:36:46]Exe (C:\c97f32e35f7ef92c3461\Windows6.1-KB958488-v6001-x64.msu) failed with 0xc8000247 - (null).

    [3/26/2012, 11:36:46]PerformOperation on exe returned exit code 3355443783 (translates to HRESULT = 0xc8000247)

    I recommend you try to activate Windows Updates. Please check out this:

    Also, you can try the suggestions listed here:
    I hope this helps.

    Best Regards,

    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Alexander Sun Friday, April 06, 2012 6:01 AM
    Tuesday, March 27, 2012 9:52 AM