none
exited with code 255

    Question

  • <?xml version="1.0" encoding="utf-8"?>  
    <Project ToolsVersion="12.0"   xmlns="http://schemas.microsoft.com/developer/msbuild/2003"> 
    	<PropertyGroup>  
    		<LocalProjectPath>C:\Users\rodionov_v\Desktop</LocalProjectPath>  
    		<LocalizationParameters>ru</LocalizationParameters>
    		<DisplayVersion>DisplayVersion</DisplayVersion>  
    		<PluginVersion>PluginVersion</PluginVersion>    
    		<AndroidPackage>PluginVersion</AndroidPackage>    
    		<DropLocation>C:\Users\rodionov_v\Desktop\Local</DropLocation>
    	</PropertyGroup>  
    
    
    <Target Name="KudKpdGenerate2" DependsOnTargets="KudKpdGenerate" AfterTargets="KudKpdGenerate">  
    	<Message Text="TEST1" Importance="normal" />
    	<Message Text="TEST2" Importance="normal" />
    	<Message Text="TEST3" Importance="normal" />
    	<Message Text="TEST4" Importance="normal" />
    	<Message Text="TEST5" Importance="normal" />
    	<Message Text="TEST6" Importance="normal" />
     </Target>  
    
    <Target Name="KudKpdGenerate">  
    
    <Message Text="KudKpdGenerate" Importance="normal" />
    
    
    	<CreateItem Include="$(LocalProjectPath)\KES_$(LocalizationParameters).kud">
          <Output ItemName="files" TaskParameter="Include" />
        </CreateItem>
    
        <CreateItem Include="$(LocalProjectPath)\KES_$(LocalizationParameters).kpd">
          <Output ItemName="files" TaskParameter="Include" />
        </CreateItem>
    
    
        <Exec Command="file_generator.exe $(LocalProjectPath) $(LocalizationParameters) $(DisplayVersion) $(PluginVersion) $(AndroidPackage)" WorkingDirectory="C:\Program Files (x86)\MSBuild\12.0\Bin"></Exec>
    	<Copy SourceFiles="@(files)" DestinationFolder="$(DropLocation)" />
    
    
     </Target>  
    
    </Project>

    I try to execute script but everytime i get message "the command exited with code 255"and  build is failed
    What i do wrong?

    Thx.

    Thursday, January 25, 2018 12:29 PM

All replies

  • Hi UIman95,

    Welcome to MSDN forum.

    The error code "255" usually means that it is not able to find the file you are asking it to execute. So you should check the script and make sure all the path in the script is correct. Especially the execute command

    "<Exec Command="file_generator.exe $(LocalProjectPath) $(LocalizationParameters) $(DisplayVersion) $(PluginVersion) $(AndroidPackage)" WorkingDirectory="C:\Program Files (x86)\MSBuild\12.0\Bin"></Exec>"

    First, make sure the file_generator.exe and the script are in the same folder, or you can not call it directly.

    Second, are there any spaces between these variables $(LocalProjectPath) $(LocalizationParameters)?

    You can run this command directly in the CMD, make sure it can be executed successfully.

    If above still not help you, please share your all build log here.


    MSDN Community Support Please remember to click &quot;Mark as Answer&quot; the responses that resolved your issue, and to click &quot;Unmark as Answer&quot; if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 26, 2018 6:41 AM