none
Visual Studio 2015 to Stop Underlining Errors and Stuff

    Question

  • In VS 2010 and 2013 I didn't have all the annoying underlines (squigglies) being created under my code as I am editing. Now in VS 2015 there are squigglies everywhere. It is frustrating when the squigglies move around on the screen faster than I can squish them. Make them all die !!!

    How do I stop this? I don't see anything under options/text editor/advanced/intellisense or anything...


    David Beavon

    Friday, July 24, 2015 3:37 PM

Answers

  • Hi David,

    Thank you for posting in MSDN forum.

    As far as I know that when we add code or build solution, we may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in our code. Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings.

    https://msdn.microsoft.com/en-us/library/efc4xwkb.aspx?f=255&MSPPError=-2147217396

    So it is default that if your code exists some error or warning, it will display these error or warning by underlines in VS IDE.

    Therefore, I suggest you'd better need to ensure if there exist some error or warning in your code compile.

    However, about you want to disable this underlines error for your code editor in this VS2015. I tried to find this underlines error in the editor option by going to Tools->Options->Text Editor->C# or C++ or VB->Advanced.

    But I found that I am also not find this underlines error in the editor option to disable it from this VS2015.

    So I suggest you could submit this feedback to Microsoft Connect feedback portal:http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx , Microsoft engineers will evaluate them seriously.

    After you submit the feedback, you can post the link here which will be beneficial for other members with the similar issue.

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, July 27, 2015 6:09 AM
    Moderator

All replies

  • Hi David,

    Thank you for posting in MSDN forum.

    As far as I know that when we add code or build solution, we may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in our code. Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings.

    https://msdn.microsoft.com/en-us/library/efc4xwkb.aspx?f=255&MSPPError=-2147217396

    So it is default that if your code exists some error or warning, it will display these error or warning by underlines in VS IDE.

    Therefore, I suggest you'd better need to ensure if there exist some error or warning in your code compile.

    However, about you want to disable this underlines error for your code editor in this VS2015. I tried to find this underlines error in the editor option by going to Tools->Options->Text Editor->C# or C++ or VB->Advanced.

    But I found that I am also not find this underlines error in the editor option to disable it from this VS2015.

    So I suggest you could submit this feedback to Microsoft Connect feedback portal:http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx , Microsoft engineers will evaluate them seriously.

    After you submit the feedback, you can post the link here which will be beneficial for other members with the similar issue.

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, July 27, 2015 6:09 AM
    Moderator
  • How to disable squigglies in Visual Studio 2015:

    Tools -> Options -> Text Editor -> C/C++ -> Advanced -> IntelliSense -> Disable Squiggles : set this options to True. 

    Thursday, February 16, 2017 1:42 AM
  • Little Late, but the answer in VS2015 is

    Tools->Options->Text Editor->C/C++->Advanced->Disable Squiqqles

    This was for C++.  Use the language you want.

    Friday, January 19, 2018 3:22 AM