none
Window xaml auto loads when debugging RRS feed

  • Question

  • Hello,

    I have noticed in vs 2019 recently, that when I am debugging a project, the main window xaml code page will auto load in preview mode, and stay there when I stop debugging.  This also happens with other windows that are relevant to the UI action, but are not loaded by me before or during debugging.  If I close the window during or before debugging, it till autoloads, so its not in the 'cache of loaded documents'  Its really annoying for my project, because it covers the page I'm actively watching for debugging.  (VB.Net WPF project application, .Net 4.7)

    Does anybody know about this feature and how to turn it off?

    Thank you,

    jamie johnson


    jvj

    Monday, November 11, 2019 5:24 PM

All replies

  • Hi Jamie,

    Welcome to MSDN forum.

    Based on your description, please go to Debug/Options/Debugging/General, then disable "Preview selected elements in live visual tree".

    If it doesn't work, you could go to Tools/Import and Export settings.., then reset the setting of VB. And to exclude the impact of 3rd plugin, you could also run the VS as safe mode, then check if it could work.

    Note: Run VS as safe mode: type "devenv /safemode" in developer command prompt.

    Look forward to your feedback.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, November 12, 2019 2:20 AM