locked
VSTS Build Agents Not Authenticating RRS feed

  • Question

  • One of 6 servers in our TFS Agent Queues stopped authenticating to TFS online without reason sometime between Thursday, 6/1/2017 and Friday, 6/2/2017.  The Agent logs in the _diag folder indicated that it was not allowing the agent to authenticate to the agent queue in TFS Online.

     

    Our standard user is an administrator of the queue and pools in TFS and has the same credentials used on all our VSTS build servers.  We only started experiencing this issue with one of them.

     

    -          We have checked our licensing to insure we have enough slots for the servers we are building.

    -          We have tried different Personal Auth Tokens and Username/Password combinations for different users who are also Administrators of the Agent Queues and we have tried different Agent Queues.

    -          Finally, we considered it being a problem with the Ubuntu server itself so we terminated the server and rebuilt it then attempted to reinstall the VSTS Agent from the downloaded tarball.

    -          When this failed as well, we tried using both the latest installer from TFS as well as the installer we’d used previously on all our other agents that are working.

     

    The result is we cannot get a new Ubuntu 16.04 build server to properly authenticate to the Agent Queues in TFS.

     

    Environment details:

    vsts@ip:~/vsts_agent$ cat /etc/lsb-release 

    DISTRIB_ID=Ubuntu

    DISTRIB_RELEASE=16.04

    DISTRIB_CODENAME=xenial

    DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS"

     

    Kernel info:

    vsts@ip:~/vsts_agent$ uname -a

    Linux ip.4.4.0-64-generic #85-Ubuntu SMP Mon Feb 20 11:50:30 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

     

    Installation command being executed:

    vsts@ip:~/vsts_agent$ ./config.sh --unattended --acceptteeeula --url  <VSTS URL> --auth PAT --token  PERSONAL_AUTH_TOKEN --pool QUEUE_NAME --agent `hostname` --work _work

     

    >> End User License Agreements:

     

    Building sources from a TFVC repository requires accepting the Team Explorer Everywhere End User License Agreement. This step is not required for building sources from Git repositories.

     

    A copy of the Team Explorer Everywhere license agreement can be found at:

      /home/vsts/vsts_agent/externals/tee/license.html

     

     

    >> Connect:

     

    Connecting to server ...

    The requested operation is not allowed.

    • Moved by Limitxiao Gao Wednesday, June 7, 2017 5:25 AM Related to VSTS
    Tuesday, June 6, 2017 7:03 PM

All replies

  • Hi Sherrill E Darby,

    This forum is discussing Team Foundation Server. Your issue is related to Visual Studio Team Service. I will move this thread to corresponding forum.

    Best Regards
    Limitxiao Gao


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, June 7, 2017 5:24 AM
  • I would suggest you open a troubleshooting Support Ticket here as it requires investigation.
    -----------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    • Proposed as answer by Sheethal J S Friday, June 9, 2017 10:22 AM
    Thursday, June 8, 2017 8:37 AM