none
Help Viewer 2.1 Problem: Cannot Fetch help content RRS feed

  • Question

  • Hello, my name is Daniel. I've been using the visual studio 2013 help viewer for a while. I also succeeded in down loading some help contents

    Currently though, help viewer cannot fetch the help contents for me to select and download the ones i want. It gives the message in the status bar

    "Error occurred. Click here for details"

    and when I click, I get the following Message

    "An error occurred while checking for updates: Unable to complete requested task because of network connectivity issues. Unable to connect to http://services.mtps.microsoft.com/ServiceAPI/VisualStudio12/en-us. Check your internet connections. Check Your network connection and try again"

    "An error occurred while determining the list of available content: Unable to complete requested task because of network connectivity issues. Unable to connect to http://services.mtps.microsoft.com/ServiceAPI/VisualStudio12/en-us. Check your internet connections. Check Your network connection and try again"

    I am browsing very fine; my internet doesn't seem to have any problems. I even downloaded some samples code (ASP.net VB, C#, etc) from extensions and updates just to test the internet connection, and they downloaded fine.

    I really need help solving this problem. Thanks so much

    Saturday, November 2, 2019 6:40 AM

All replies

  • Hello,

    Looks like Microsoft removed the page as per a 404 response meaning the page does not exists.

    {
        "phrase": "ExternalConnectionFailure",
        "retriable": false,
        "component": "Microsoft OfflineBook APIService",
        "details": "The remote server returned an error: (404) Not Found.",
        "error_code": 50001,
        "error_message": "The remote server returned an error: (404) Not Found."
    }


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Saturday, November 2, 2019 9:39 AM
  • Thanks for the response Karen. But how do I resolve it?
    Sunday, November 3, 2019 12:08 PM
  • Thanks for the response Karen. But how do I resolve it?

    Microsoft appears to have removed the page and there is no replacement. I you search for this only these version of Visual Studio help are currently available.


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Sunday, November 3, 2019 1:05 PM
  • Hi adusen45,

    Thank you for posting here.

    I have reproduced this error on my side, the url should be "https://services.mtps.microsoft.com/ServiceAPI/catalogs/VisualStudio12/en-us"

    And I could access the url successfully, but it will automatically change "http://.." to "https://..". It might be the reason to cause it. So I read the installation file in "C:\Program Files (x86)\Microsoft Help Viewer\v2.1", and try to modify it, but I did not find related file to change it.

    So I'm sorry the url should be a default value, and we recommend you could use Help viewer with VS2015 and later, sorry for this inconvenience.

    Best Regards.

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, November 6, 2019 10:06 AM
  • Hi Daniel,

    Did your issue solved?

    If this issue still persists, maybe you could follow below steps to add corresponding cab files manually and this might be helpful.

    (1) Create a new folder on your computer(like “D:\SampleDownloadedContentCabs”).

    (2) Download desired cabs to this folder from this link: https://services.mtps.microsoft.com/ServiceAPI/catalogs/VisualStudio12/en-us

    (3) Create below HelpContentSetup.msha as a txt file and note to change the default cab name to the files you downloaded just now. Save it to the above new folder.

    <html xmlns="http://www.w3.org/1999/xhtml">
    <head />
    <body class="vendor-book">
        <div class="details">
            <span class="vendor">Microsoft</span>
            <span class="locale">en-us</span>
            <span class="product">Microsoft Help Content</span>
            <span class="name">Microsoft Help Content</span>
        </div>
        <div class="package-list">
            <div class="package">
                <span class="name">v2visual_studio_2011_fundamentals_b906_vs_110_en-us_2</span>
                <span class="deployed">False</span>
                <a class="current-link" href="v2visual_studio_2011_fundamentals_b906_vs_110_en-us_2(1e31c917-543f-b7d0-3f24-c8e533ec1382).cab">v2visual_studio_2011_fundamentals_b906_vs_110_en-us_2(1e31c917-543f-b7d0-3f24-c8e533ec1382).cab</a>
            </div>
            <div class="package">
                <span class="name">v2visual_studio_2011_fundamentals_b906_vs_110_en-us_3</span>
                <span class="deployed">False</span>
                <a class="current-link" href="v2visual_studio_2011_fundamentals_b906_vs_110_en-us_3(91224dba-aa88-6d08-116c-8a942b7c0974).cab">v2visual_studio_2011_fundamentals_b906_vs_110_en-us_3(91224dba-aa88-6d08-116c-8a942b7c0974).cab</a>
            </div>
            <div class="package">
                <span class="packageType">branding</span>
                <span class="name">VisualStudio_2011_Branding_en-US</span>
                <span class="deployed">True</span>
                <a class="current-link" href="VisualStudio_2011_Branding_en-US(1bd6e667-f159-ac3b-f0a5-964c04ca5a13).cab">VisualStudio_2011_Branding_en-US(1bd6e667-f159-ac3b-f0a5-964c04ca5a13).cab</a>
            </div>
        </div>
    </body>
    </html> 

    (4) Open Help Viewer 2.1 and choose Manage Content tag -> select Disk -> browse to the above folder you created -> and you should see a list of content to install. In the Action column, select add -> Update then check if it works.

    This document Installing Content From Downloaded Help Viewer 2.0 cabs explains more details and you could refer to it, but please note it’s for 2.0 and for 2.1 you should go to the corresponding link to download cab files.

    I hope all above could help you.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.




    Friday, November 22, 2019 8:46 AM