none
Query added Auto Complete Box in Lightswitch Data Grid not the same on the default Modal screen RRS feed

  • Question

  • Hi

    I have a simple two  tables Clients  and Directors  with a one to many relationship and a query called ActiveDirectors selecting Directors with a valid status. 

    Client editable Grid screen created.  Run it and the for the client row selected the directors shows all.  for a new record (Default Modal Screen) the same. ( All CORRECT)

     Add Query ActiveDirectors to screen, alter property  of auto complete box  Director from "Auto" to   Choice:  "ActiveDirectors" query.

    Run it and for the client row selected  only active Directors is displayed in the drop down (CORRECT),  for a  new record (default modal screen)  all Directors show  (NOT CORRECT) 

    Is there any way of fixing this as the screen took hours to set up. Can the default screen be cleared and reset to the current screen somehow?


    Tuesday, September 3, 2013 8:16 AM

Answers

All replies

  • Hi,

    You can create a custom Add or Edit Dialog (see this blog post). Then on the Dialog you can use the same ActiveDirectors query.

    Best regards,
    Huy

    • Marked as answer by pp8357 Pieter Friday, September 6, 2013 8:31 PM
    Friday, September 6, 2013 5:52 PM
  • Thanks Huy

    I still think its a bug.  I have also gone on to add Table elements  to the drop down and are experiencing further problems in that excel cant export it Parameter key: Null  so I guess start again. (i should say that there are three drop downs on this row. maybe its to many.

    Friday, September 6, 2013 8:31 PM