none
CodeCoverage.exe from Teamtools for a large native C++ 64 bit application RRS feed

  • Question

  • Hi everybody,

    I try to use the CodeCoverage.exe collect to gather information on the coverage of a large native C++ 64 bit application. But if I start CodeCoverage.exe collect /output:test.coverage myApp.exe, my app starts but not completely, it seems that something hangs. Is it possible to get more logging information or is there a reason why the app does not start completely?

    Thank's,

    Stefan

    Wednesday, January 30, 2019 11:36 AM

All replies

  • Hi Stefan,

    How about changing the build platform target(Any CPU/x86/x64) and using the debug mode?

    As you said that it was a large app, whether all projects have the same issue?

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 5, 2019 2:43 PM
    Moderator
  • Hi Jack,

    I created a configuration file in which I mention all exe and dll from which I want to get coverage information. I get a coverage file but some methods from the source code are not part of the coverage information (even as not covered). I run the CodeCoverage.exe against a release build. Is it necessary to use a debug build or to switch the optimization off?

    Best regards,

    Stefan


    • Edited by stefansta Thursday, February 14, 2019 7:00 AM
    Tuesday, February 12, 2019 5:00 PM