Unable to open *.exe


  • I previously using microsoft visual c# 2008 express. And Im able to open the *.exe file build in .net3.5.
    But today after i install visual c# 2010 express without uninstall 2008 express. Then I cant open the *.exe file.

    Any suggest? 

    Tuesday, November 29, 2011 9:25 AM

All replies

  • What do you mean with "open *.exe files"?

    At the moment I am wondering what you tried. Normaly you can start EXE files produced. But I wouldn't call it opening.

    Normaly you do not open an assembly (DLL / EXE). You can add references, you can view contents in an object browser (not sure that this is part of the Express Edition), ...

    In the past I had some tools to open and edit the resources of EXE files. But that is something that is not supported by Visual Studio as far as I know.

    Maybe you can describe exactly what you are looking for.

    With kind regards,


    Tuesday, November 29, 2011 10:44 AM
  • Okay. This is my situation. Previously , my pc installed visual studio c# express 2008. Im able to start/run the exe file i build from my project.  It also able to start/run the exe i get from friend.

    But recently i install visual studio c# express 2010 without uninstall 2008 express. So now my pc have 2 version of c# express. At this moment, i still able to start/run the exe i built from my project last time. But the problem is i cant start/run the exe i get from friend which previously able to start/run. 

    He said he build the exe with vs c# 2010 express and .net4.0 and i checked mine also .net4.0 and has 2 version of vs c# (2008,2010)...

    When i start/run the exe from my friend. it straight away close and doesn't prompt any error message box. 





    Wednesday, November 30, 2011 3:53 AM
  • Hi,

    this could be, because the runtime cannot load / initialize the assembly / the runtime or maybe the application throws an exception for some reason that is not handled.

    At the moment I am wondering, why you do not see any message. I would expect a message. Maybe you try to start the exe from a CMD window.

    Such problems can have multiple reasons. Some possible reasons can be:
    - invalid config file
    - referenced assembly is not available
    - Exception in his code that is not catched.

    Maybe you should ask your friend about the application, too. He could:
    - tell you about the things it is doing (e.g. write a file in c:\temp and that directory does not exist - just as an example!)
    - tell you about the references (This can bee seen inside the Solution explorer of Visual Studio)
    - He could also catch exceptions and display messages. (It is ok if an exception cannot be handled. But the problem should be visible somehow!)

    Regarding logging: TraceSource and TraceListener are great classes build into the .Net Framework. It is quite nice to use a TraceSource inside the application and configure tha listeners inside the config file. If more features are required (normaly that should be more than enough for small projects), then log4net is a great library which could be used. (Or the enterprise Library also offers enhanced logging options!)

    With kind regards,


    Wednesday, November 30, 2011 8:25 AM
  • Thanks. I tried start the *.exe with cmd prompt but still the same. Im just able to see a window open then straight away close and never prompt error msg. I will contact my friend later on. 




    Thursday, December 01, 2011 5:35 AM
  • That is not normal, should be something technical on your computer related to Framework 4 (I've read this thread), be aware that it has an update to framework 4 so maybe has your friend used that.

    Also take care that you have the full version installed if your friend has that also.

    Be aware there is no framework 4.0 because of a strange decision by some persons at Microsoft that one has the name 4, although the updates are called 4.0.2.


    Thursday, December 01, 2011 6:23 AM
  • Thank you Konrad and Cor for your great contribution.


    Hi murnesty,

    Welcome to the MSDN forum!

    Have you updated the VS express 2010 to SP1?

    You can download the SP1 Installer from the following link:

    Microsoft Visual Studio 2010 Service Pack 1 (Installer)

    Please let us know if it helps.

    If you have any questions, please feel free to let us know.

    Have a nice day!


    Yoyo Jiang[MSFT]
    MSDN Community Support | Feedback to us

    Thursday, December 01, 2011 6:38 AM
  • Hi murnesty,

    Is there any update on this issue?

    Please feel free to let us know if you have any questions.

    Have a nice day!


    Yoyo Jiang[MSFT]
    MSDN Community Support | Feedback to us
    Friday, December 09, 2011 4:53 AM