Can't Install .NET Framework 2.0



    I'm trying to install the latest display drivers for my ati graphics card but they require .net framework 2.0 for the ati control panel to work, i've tried installing it through windowsupdate and i get the error 0x643 so then i downloaded the installer and it gives the error:


    "error 25015.Failed to install assembly 'C:\windows\\framework\v2.0.50727\Microsoft.VisualBasic.Vsa.dll' Because of System error: 0x80131107"


    I have been looking through the internet for a solution and tried these:


    • I've tried uninstallig everything to do with .net framework then reinstalling it again to no avail.
    • i've stopped the update service then cleared the Software Distribution folder then started it again which didn't work.
    • and i've renamed all mscoree.dll all to mscoree.old then tried to install again.


    I have the .Net Framework 1.1 installed with all the updates and im running windows xp home edition. If i haven't given enough information then just ask and i'll try to get it.


    Thanks, cal.

    Friday, September 21, 2007 11:35 AM


All replies

  • Hi Calpol,

    You can try to use the following steps to solve this problem:

    1. Download the .NET Framework cleanup tool and choose to cleanup the version of the .NET Framework that is causing problems on your system
    2. Download and install the version of the .NET Framework that you cleaned up in step 1 (such as the .NET Framework 1.0, .NET Framework 1.1 or .NET Framework 2.0)
    3. (optional) Download and run the .NET Framework verification tool to double-check that all .NET Framework files are correctly installed
    4. Download and install the desired .NET Framework service pack (such as .NET Framework 1.0 SP3 or .NET Framework 1.1 SP1) by running the setup package directly instead of using Windows Update.  Running it directly will allow the service pack setup to display error dialogs instead of having Windows Update suppress them

    For more details, please visit What to do if other .NET Framework setup troubleshooting steps do not help.

    Hope this helps!


    Thursday, September 27, 2007 8:02 AM
  • Thank you!!

    I did it step by step and works!!!!!!

    Saturday, April 19, 2008 1:41 PM
  • I concur.  These steps were the perfect solution.  Once I used the clean-up tool to remove Framework 2.0 files that were littering my computer it installed perfectly.  THANX!
    Monday, August 10, 2009 10:32 AM
  • Thank you soo much!  After spending an hour and a half trying other solutions, your solution to my being unable to install .net framework version 2.0, was the one that worked.  Again, thank you for your help!
    Wednesday, October 27, 2010 5:24 AM
  • I've followed the steps above, and the verification tool states that .NET framework is installed, however every time I reboot/restart my P.C. a pop-up declares that it cannot continue because Framework 2.0 is not installed. What can I do?

    My computer operates fine for the most part, however certain applications, flash namely, take much longer to function and delays frequently. Are these related?

    Any feedback would serve helpful. 

    thank you


    Sunday, May 22, 2011 3:45 AM