Cant install Microsoft NET Framework 4


  • I cant install net framework 4.  It downloads all the necessary components but wont "install" them.  Here is my file.!113&authkey=!AHvV-k_Wa7DuN-k
    Sunday, July 29, 2012 9:02 PM


All replies

  • Check your Windows Update service.

    About how to activate Windows Update, you can check out this:

    Once you verify your WU, try these steps.

    Follow ALL these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    After you run Collect.exe, you'll find in your %temp% directory. Please upload to a public site, like SkyDrive, and post the link here.

    Sunday, July 29, 2012 9:15 PM
  • I cant open my Windows Update in the control panel.  Everytime i open the control panel and try to click on windows update it turns non responsive and I cant close it, kill it (task manager) or anything it just freezes and wont do anything.

    Update:  Here is my

    Sunday, July 29, 2012 9:26 PM
  • I am having the same exact issues when attempting to install the .NET Framework and I also get my control panel locking up when I attempt to go into the windows updater. 
    Sunday, July 29, 2012 11:24 PM
  • Hi D3ADLYxK1LLER and SBurch,

    If we want to install .NET 4 successfully. We need to keep our OS updated.

    It seems you also have Windows Update error.

    Please open a new thread here to solve Update issue first.

    I also recommend you refer to this page to troubleshoot WU problems and refer to this page to scan your OS for virus

    If you have solved WU issue and still have error when installing .NET 4, please feel free to let me know.

    BTW, I have checked D3ADLYxK1LLER 's log. The only error was "0xc8000247

    You can refer to this page of the same error which is related to WU

    Or this thread


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Monday, July 30, 2012 9:29 AM
  • Hi there,

    I was reading this thread because I'm experiencing a similar situation, but when I follow the provided solutions in this thread I get nowhere.

    At first the problem was a missing signature in .NET framework, which made it impossible to install or uninstall the software. Now after trying all kinds of different things, the error message has changed to ''General trust Issue'' <this might sound a bit dumb but it's a free translation from the dutch error message.

    I've collected the log files and uploaded them at this adress:!AunjVF0W72Wea5w2ox7GF8MmEWA

    I'm at a loss on how to solve this, any help would be much appreciated.

    Friday, July 15, 2016 7:25 AM
  • Hello Mr. Sweers.

    From your install log:

    D:\6fa4214c70cedf3dce6033e5a06a8eb7\SetupUtility.exe Signature could not be verified for SetupUtility.exe
    [7/15/2016, 9:4:56]No FileHash provided. Cannot perform FileHash verification for SetupUtility.exe
    [7/15/2016, 9:4:56]File SetupUtility.exe (D:\6fa4214c70cedf3dce6033e5a06a8eb7\SetupUtility.exe), failed authentication. (Error = -2146762496). It is recommended that you delete this file and retry setup again.

    Friday, July 15, 2016 1:53 PM