none
Unable to use Just-In-Time debugger in Visual Studio 2019 RRS feed

  • Question

  • When I try to turn on Just-In-Time debugging, I see a warning message at the bottom of the window that reads, "Another debugger has registered itself as the Just-In-Time debugger.  Fix by enabling Just-In-Time debugging or running Visual Studio repair".  If I ignore it and try to save, I get a popup window with the error: "Settings for Just-In-Time debugging could not be applied.  Visual Studio Just-In-Time Debugger registration needs to be repaired, and Visual Studio does not have the necessary privileges to run the registration.  To enable Just-In-Time debugging, run Visual Studio rus as an administrator and enable Just-In-Time debugging or run Visual Studio setup in repair mode".

    I have tried running repair several times but continue to get this same result.  I also have Visual Studio 2017 and it is doing exactly the same thing.


    Thursday, May 16, 2019 11:50 AM

All replies

  • The just in time debugger is registered in the Windows registry. This tells you what registry keys control the debugger.

    My suggestion would be to disable the debugger in the registry by deleting the 4 registry entries that it tells you to. (2 if you are on a 32 bit system). After this, run Visual Studio as an administrator and try enabling just in time debugging again.

    If this doesn't work then to be honest I would suggest you reinstall/reimage the computer. Registry errors can be really painful to deal with and just reinstalling is often the easiest option.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.

    Thursday, May 16, 2019 12:40 PM
  • Thanks for the reply.  I came across that same link before I posted my issue, but I tried it again just to be sure and it still does not work.  It seems like this is not a very uncommon issue.  Hopefully there is a way to fix this outside of reinstalling or reimaging my box. 
    Thursday, May 16, 2019 4:46 PM
  • Hi btyansp,

    Sorry to trouble you and just want to confirm that if your issue is solved or not, if not, please feel free to let us know, we will try our best to help you out.

    BTW, if you think the reply is helpful and could please mark it as answer, that benefits for other community members who meet the similar issue, thanks in advance.

    If you have any other VS IDE issues, please let us know.

    Have a nice day!

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, May 20, 2019 2:08 AM
  • No, the issue is not resolved.  I still need assistance with this issue.

    Thank you!

    Monday, May 20, 2019 11:14 AM
  • Hi btyansp,

    After experiment in my side, please follow the steps below:

    #1 Please open register editor, open HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

    #2 Please right-click the blank area, then add the new String Value which called "Auto", and set the value as "1".

    #3 Please open the visual studio as administrator, then re-enable the debugging.

    If there is update details, please feel free to contact us.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Tuesday, May 21, 2019 8:44 AM
  • I do not seem to have that registry setting:

    Tuesday, May 21, 2019 11:22 AM
  • Hi bryansp,

    I share a reg file using onedrive, please download and run to add it to the registry. Then re-open visual studio to do the option.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, May 22, 2019 2:01 AM
  • Thank you for the registry settings.  I imported them and started Visual Studio as an administrator, but when I go to turn on the Just-In-Time Debugger, I get the same results.

    I exported my registry settings and took a screen shot just so you can see that the values are set:

    Wednesday, May 22, 2019 12:11 PM
  • Hi btyansp,

    Did you restart machine then restart visual studio?

    If this issue persists, I'm afraid the appropriate method currently is to reinstall the machine currently, which is like the Darran Rowe's suggestion.

    Sorry for this inconvenience.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, May 23, 2019 5:25 AM
  • Wow...  Well, thanks for your help anyway.  Reinstalling the operating system and starting from scratch is not very practical for me to do now.  Since there is no other resolution, I will just have to live without the Just-In-Time debugger for the time being.  
    Thursday, May 23, 2019 11:44 AM
  • Hi bryansp,

    Thank you for understanding.

    If this issue is solved in the future, we will appreciate that you could share the solution here, which will be beneficial to other community members with the similar issue.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, May 24, 2019 10:07 AM