none
ASP.net Website configuration tool ERROR RRS feed

  • Question

  • Hi guys,

    Could anyone please help! I'm trying to view the "ASP.NET Configuration Tool" and all I get is this message:

    An error was encountered. Please return to the previous page and try again.

    The following message may help in diagnosing the problem: System.UnauthorizedAccessException: Attempted to perform an unauthorized operation. at System.Security.AccessControl.Win32.SetSecurityInfo(ResourceType type, String name, SafeHandle handle, SecurityInfos securityInformation, SecurityIdentifier owner, SecurityIdentifier group, GenericAcl sacl, GenericAcl dacl) at System.Security.AccessControl.NativeObjectSecurity.Persist(String name, SafeHandle handle, AccessControlSections includeSections, Object exceptionContext) at...

    Any help will be appreciated!

    Thank you

     

     

    Thursday, March 9, 2006 11:56 PM

Answers

  • Ok I figured this out.  Hmmm should I spill the beans?  The problem is in the Path.  My path included an "&".  C:\Documents and Settings\Lisa&Rob\My Documents\Visual Studio 2005\WebSites.  VWD does not like the "&" in the path.  Even if you move the site to c:\web&sites\ you will still have the problem.  c:\websites works perfect.

     

    Hope this helps other folks.

    Bob

    Tuesday, April 25, 2006 1:12 PM
  • Hi!

    How are you trying to run the tool?  Directly from VWD, or other way?  Is your web site running locally, or on a remote server?

    I'd check to make sure that all of the permissions are set correctly, that your application is running in full trust and so forth.

    The best place for asking ASP.NET questions is on the ASP.NET community site, and in the forums there. Check out http://www.asp.net/welcome.aspx?tabindex=1&tabid=39.

    HTH,

    PEte

    Saturday, March 11, 2006 2:04 AM
    Moderator

All replies

  • Hi!

    How are you trying to run the tool?  Directly from VWD, or other way?  Is your web site running locally, or on a remote server?

    I'd check to make sure that all of the permissions are set correctly, that your application is running in full trust and so forth.

    The best place for asking ASP.NET questions is on the ASP.NET community site, and in the forums there. Check out http://www.asp.net/welcome.aspx?tabindex=1&tabid=39.

    HTH,

    PEte

    Saturday, March 11, 2006 2:04 AM
    Moderator
  • Thanks alot
    Saturday, March 11, 2006 11:21 AM
  • Hi kevinho,

    Did you ever find an answer to this problem?  I have the same problem.  Thanks  Bob

    Tuesday, April 25, 2006 11:28 AM
  • Ok I figured this out.  Hmmm should I spill the beans?  The problem is in the Path.  My path included an "&".  C:\Documents and Settings\Lisa&Rob\My Documents\Visual Studio 2005\WebSites.  VWD does not like the "&" in the path.  Even if you move the site to c:\web&sites\ you will still have the problem.  c:\websites works perfect.

     

    Hope this helps other folks.

    Bob

    Tuesday, April 25, 2006 1:12 PM
  • This really helped.  Apparently some other characters in the path name will cause the same issue.
    Thursday, October 5, 2006 6:17 PM
  • Buddy,

    Thank you so much.
    Your post about pathname of the website containing folder is of great help.
    Hope to interact with you over such issues
    Thursday, February 21, 2008 12:36 PM
  • Doh! After struggling with this problem for an hour or so I finally solved it.

    The problem: My files were stored in a Directory called "C#"

    I know, I know, I know.

    Thanks Bob - once I saw your post I kicked myself, it's all working now...


    MarkP
    Thursday, November 26, 2009 10:06 AM