none
Getting '403-Forbidden' running a web performance test in visual studio during a Microsoft.SharePoint.Portal.SuiteNavData.GetSuiteNavData request RRS feed

  • Question

  • Hi guys,

    i'm trying to perform diferent webtest in visual studio (simple visint a page, uploading files, downloading files, etc) and after recording there are some automatic requests that appear in the webtests. Some of these automatic requests are the .../_api/Microsoft.SharePoint.Portal.SuiteNavData.GetSuiteNavData requests and in the majority of them i'm receiving a 403 Forbidden Error wich I think it's making me impossible to complete the tests.

    Can anyone help me finding a solution to overcome this issue?

    Monday, July 24, 2017 3:33 PM

Answers

  • Hi Test Me 4 Real,

    The 403 forbidden error means the request that your client sent doesn't have permissions to server. So the request has been sent successful to server but the server is refusing to respond to it. The provided credentials were successfully authenticated but that the credentials still do not grant the client permission to access the resource. I suggest you change other credentials which has permissions to access the resource.

    If the credentials that you provided has grant permission to access the resource, the problem should be related server that you accessed. Please contact the developer that develop the server to check whether there has some problem in server side code.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, July 25, 2017 5:37 AM
    Moderator