none
Debug my code is not saved RRS feed

  • Question

  • Hi,

    In my VS 2012 the setting "debug only my code" is not saved. Everytime I start VS the setting is not set any more. Why does VS 2012 not save this setting.

    best regards

    (the upload of the picture here does not work)

    Thursday, February 21, 2013 8:18 AM

Answers

All replies

  • Did you change any other settings in the debugging dialog?

    I ask because the "Enable Just My Code" setting (the one I presume you are referring to) is selected by default, and is always on when I start VS 2012 Ultimate here.

    If you did change other settings, that could be the issue.

    You can try resetting to defaults using the Tools->Import and Export Settings... dialog.

    Thursday, February 21, 2013 2:49 PM
  • resetting does not help either, next start "enable just my code" is deactivated again.

    It seems that this setting is not saved. Can 3party tools influnce this "settings save"?

    (Suggestion: Make the Option Dialog Window resizeable, it would be good to make it bigger, no need for a fixed window)


    • Edited by WoAx Thursday, February 21, 2013 3:10 PM
    Thursday, February 21, 2013 3:09 PM
  • Third party tools most certainly could affect your situation. To check, you should disable/uninstall all third party add-ins, then check settings behavior. I have further checked three more machines here with VS 2012 installed. Behavior of the setting  "Enable Just My Code" is as I described earlier on all machines. I have no third party add-ins installed.

    For your suggestion, please post on Microsoft Connect so the VS team will see it:

    https://connect.microsoft.com/VisualStudio

    Thursday, February 21, 2013 3:35 PM
  • Hi WoAx,

    Thank you for posting in the MSDN forum.

    As pvdg42’s suggestion, it is enabled in default settings, so I doubt that it is related to your VS. Maybe you could try to open your VS as the admin, check it again.

    In addition, we often use the followings options to check the VS IDE issue.

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    And then restart your VS, check it again. If still no help, maybe you could try to repair your VS.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, February 22, 2013 10:02 AM
    Moderator
  • thx for help

    Your tips unfortunate do not work (open as admin, deactivate addins)

    I opened a bug https://connect.microsoft.com/VisualStudio/feedback/details/779918/setting-debug-just-my-code-is-not-saved


    Monday, February 25, 2013 8:29 AM
  • I've the same problem, added to the connect, but the issue is closed. :(

    Wednesday, April 17, 2013 9:52 PM
  • I have the same issue too... But I'm using Visual Studio 2013.


    • Edited by dbrighton Wednesday, June 4, 2014 2:35 PM
    Wednesday, June 4, 2014 2:35 PM