none
I can´t open dataset designer with any dataset: object reference not set to an instance of an object RRS feed

  • Question

  • Hi, since the last visual studio 2017 update i can't open the dataset designer view with any of my datasets. If I try "open with" the "Common Editor Factory" is set as default, if I change it to "Dataset editor" i get the error "object reference not set to an instance of an object" again.

    I can't continue developing without this. Any help please? There is a way to downgrade to VisualStudio 2015?

    Thanks

    Thursday, July 13, 2017 5:28 PM

All replies

  • Hi Anibol,

    Unfortunately, I could nor repro this in my side.

    what I did is add -> new item  -> data ->dataset,

    Right click  Dataset in solution explorer -> open with :

    if I open it with "Common editor factory", it could not be open, but i changed to "Dataset Editor" then I could open it with no problem.

    >> There is a way to downgrade to VisualStudio 2015?

    VS2015 and VS2017 could co-exist in same machine, if you really need install VS2015 you could go to the page:

    https://www.visualstudio.com/vs/older-downloads/

    then you could select the older versions to download.

     

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, July 14, 2017 6:00 AM
  • Hi Fletcher, i have "Common editor factory" selected as default but when i change to "Dataset Editor" and mark it as default and click OK i got the error of object reference....

    What can i do?

    Thanks

    Friday, July 14, 2017 9:19 AM
  • Hi Anibol,

    This error happed to the dataset which is created in VS2015, right? Would you mind trying to add a new one in VS2017 and open it with Dataset Editor to have a see?

    I just wonder if this issue is caused by the .net framework mismatching:  

    If you change your .Net target frame to anything higher than 4.5 it should open fine.

    Website -> Start Options -> Build -> Set Target Framework ".Net FrameWork 4.5"

    Please let us know if it works.

     

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Sunday, July 16, 2017 8:59 AM
    • Proposed as answer by Fletch Zhou Tuesday, July 18, 2017 4:05 AM
    Sunday, July 16, 2017 8:59 AM
  • Hi Fletcher, my project is on .net 4.6.1 version. I've solved partially adding a DLL project and moving my datasets to that project. Now the designer seems to work but when i save a modification and exit the designer window I get the error you can see on attached capture:

    Any hint?

    Thanks

    Tuesday, July 18, 2017 6:52 AM
  • Hi Anibol,

    Thanks for your response.

    Is that Spanish? Forgive me if I do not get the error message correctly. Does the error say "object reference not set to an instance of an object" in English?

    If so, the error means that you have a bug in design mode for some custom control, perhaps there's some code in the constructor that returns null in design mode, and the null is not checked for.

    you also could try to save your project, close Visual Studio, after please reopen VS and DataSetDesigner.

    Hope it helps.

     

    Best regards,

    Fletcher

     

     


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Tuesday, July 18, 2017 8:28 AM
    • Proposed as answer by Fletch Zhou Monday, August 7, 2017 9:21 AM
    Tuesday, July 18, 2017 8:28 AM
  • very thank you.its works

    after setting this

    Website -> Start Options -> Build -> Set Target Framework ".Net FrameWork 4.5"

    Monday, March 26, 2018 10:33 AM