none
xaml editor in VS 2012 is really slow and locks up a lot RRS feed

  • Question

  • I have noticed that in VS2012 Ultimate that the xaml editor tends to freeze and take a long time to register keyboard input. I didn't have this issue in 2010 using the same Solution I am now using in 2012. Any ideas?

    I saw there were two tickets raised at MS connect, but seems like no resolution yet.

    • Moved by Forrest GuoModerator Wednesday, December 19, 2012 12:14 PM forums restructure (From:Visual Studio WPF/SL Designer)
    Tuesday, November 13, 2012 5:29 PM

All replies

  • Opening the file in "Source code (text) editor" should help a bit, but then you don't have a designer.
    Monday, December 17, 2012 8:50 AM
  • I have VS 2012 Update 3, Professional.

    I have a solution that includes 3 projects and about 30,000 lines of code.  I have a core I7 touchscreen laptop with 8 GB, which seems to run VS very quickly.

    My solution includes many Xaml files.  I have used the Xaml designer (XAML UI Designer).  However, I began to encounter slow responsiveness.  The responsiveness was really having an adverse affect on my ability to edit these files efficiently.  There was such a lag time in the IntelliSence system, such that I would have to wait for it to display, and typing ahead would result in errors.  I tried turning off the design display so as to show only the Xaml.  I also tried using some of the other editors that come with VS that have IntelliSence but do not include the design display.  However, these actions did little to relieve the slow responsiveness.  To me, the responsiveness seemed to be related to IntelliSence rather than the design graphical display.

    Some of my Xaml files were responsive to edit, whereas other were not.  This did not seem to be a function of Xaml file size.  For example, I had two files each with about 2000 lines of Xaml, one responsive and one very slow.

    In comparing the responsive and unresponsive files, I noticed that unresponsive file included the following lines which the responsive file did not:

    xmlns:d="http://schemas.microsoft.com/expression/blend/2008" xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"

    I removed these lines from my unresponsive file.  Then I saved the file, closed the file,  set the "Open With" option on a Xaml file (a right-click option) to "Automatic Editor Selector", recompiled, saved, and closed the solution.

    After closing VS, and then reopening it, and loading the solution and the unresponsive Xaml file, I found the responsiveness to be fully restored.  Editing of the Xaml file seemed to be working very efficiently.

    As I continue to work with this file, if the responsiveness degrades for any reason, I will post an update.


    Ralph

    Sunday, September 1, 2013 6:54 PM