none
Buttons work on one pc but not the other RRS feed

  • Question

  • So to make it understandable. 

    I have an app like spotify,  on one computer the play,mute etc button plays, but on mine it does not work.  Track changes etc but just does not play or play sound.   Any ideas? No errors in build etc.

    Thursday, November 14, 2019 10:06 PM

All replies

  • Maybe start your application, go to Sound Mixer (can be found in Windows using Search) and check the volumes.

    Also use the Visual Studio Debugger to check that the code is executed step-by-step as expected.

    Friday, November 15, 2019 5:49 AM
  • Hi killerbambam,

    Welcome to MSDN forum.

    According to your description,

    >> I have an app like Spotify.

    Could you share me your project type? Did you create a Spotify project or reference the external program in an VS project?  If your project is only about Spotify application, I suggest you could ask Spotify forum for a better support.

    In addition, if your Spotify app is referenced to your VS project, could you tell me the edition of VS that you use?  buttons work on the PC but not the other, I suppose you could check if the settings of two computers are the same.

    Hope all above will help you and any feedback will be expected.

    Best Regards,

    Anna 


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, November 15, 2019 9:32 AM
  • Yeah its not the sound itself.  The physical button does not change (its set to enable etc)  even the music progress bar does not move.

    Ive tried the debugger says its all dandy and good.

    Thanks though

    Friday, November 15, 2019 7:09 PM
  • No it just looks like spotify and does the same job.  I use community edition with xamarin etc 
    Friday, November 15, 2019 7:09 PM
  • Hi killerbambam,

    Welcome to MSDN forum.

    Since your app could work well on one PC, I consider this issue may be caused by the different configurations of this two PC. I mean maybe the environment, the version of platform or framework that application depends/supports on are not very same between this two computers.

    I’m not sure if there is any dependence on dlls or maybe necessary references that need to be packed with your application(.exe). If possible, you could use another computer and check if this application could just work on your computer or could work on other computers instead of “the other computer” you mentioned could not play sound.

    Maybe you copied the whole application related packages to the other computer to use, and if not or just copied .exe file, you might could try to copy the whole folder to the other computer and check if you could play sound this time.

    Hope this could help you.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Tuesday, November 19, 2019 9:11 AM
  • Hi killerbambam

    Sorry to disturb you.

    Are our suggestions useful for you to solve your issue?

    If my reply doesn’t work, please feel free to contact us, we can help you research it again.

    We are looking forward to hearing from you.

    Best Regards,

    Anna


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, November 22, 2019 10:43 AM