none
Intellisense in Visual Studio 2005 is not working

    Question

  •  

    Hi,

    I migrated a Visual C++ project from VS 2003 to 2005 and for some reason intellisense is not working there (although it does work in VS 2003). When I try to use it, say expand member list of a class it shows a message on the status line "IntelliSense: 'No additional information available' (see 'Troubleshooting Intellisense in C++ Projects' for further help). The Object Browser is working fine. I have to add this is just a container project for development (I build it with make utility), but like I said, the intellisense for the same project is working fine in VS 2003.

    Is there a difference between 2003 and 2005 preventing intellisense to work for such projects?

     

    Thanks,

    Mike.

     

     

    Friday, February 22, 2008 11:02 PM

Answers

  • Close your Visual Studio session and delete the *.ncb file. Now open Visual Studio and compile. Your Intellisense should be working again.

     

    Brian

     

     

    Friday, February 22, 2008 11:05 PM
  • Please take a look of this article about 2005 intellisense, especially the "Intellisense for Make file projects" section.

    http://www.microsoft.com/indonesia/msdn/VC2005IntelliSense.aspx#vc2005intellisense_topic6
    http://msdn2.microsoft.com/fr-fr/library/ms364071(VS.80).aspx

     

    Different from 2003, 2005 intellisense starts to parse the system headers. If you use external system, you need to set  "Include Directories", etc for your system headers so that the intellisense engine can complete the parsing.

     

    Li Shao

    Visual C++ IDE

    Monday, February 25, 2008 5:20 AM
  • Here is one trouble shooting approach that you can try:

     

    1. Set environment variable: FEACP_LOG_OPTIONS to point to a txt file such as c:\intellisense.log

    2. Delete the NCB file for the project and reload the project

    3. Repro the operation where intellisense failed

     

    You may let us know the content of the log file and we can see if there is some header files missing.

     

    Li Shao

    Visual C++ IDE

    Tuesday, February 26, 2008 6:11 AM
  • I had this same problem today with VS 2005, using a project just for editing purposes but with no makefile or any intention of building with the project.  To get the autocomplete / intellisense to work for an include file you have to add the include directory to the project.

     

    right click and go to Properties on the top level of the project, then select Configuration Properties / C/C++ / General.

     

    The top entry there will be "Additional include directories"   Add any additional include directories there for you includes that don't seem to be getting parsed.  

     

    Hope that helps, worked for me.

     

    -Matt

    Tuesday, February 26, 2008 9:40 PM

All replies

  • Close your Visual Studio session and delete the *.ncb file. Now open Visual Studio and compile. Your Intellisense should be working again.

     

    Brian

     

     

    Friday, February 22, 2008 11:05 PM
  •  

    Hi Brian,

     

    Like I said I do not compile the project, I build it with make outside of Visual Studio. But it was not required to compile a project in VS 2003 for intellisense to work - is it different in 2005?

    Friday, February 22, 2008 11:08 PM
  • I don't know if compiling is required, but it does rebuild the intellisense database (*.ncb file).

    Did you perhaps refer to that article (Troubleshooting Intellisense in C++ projects) that the IDE referred you too?
    Saturday, February 23, 2008 12:18 AM
  •  

    Yes, I see that the ncb file gets rebuilt after I delete it and reload the project. But it still does not fix the problem.

    I did check that article, but I could not find the answer there.

    Saturday, February 23, 2008 12:24 AM
  • Please take a look of this article about 2005 intellisense, especially the "Intellisense for Make file projects" section.

    http://www.microsoft.com/indonesia/msdn/VC2005IntelliSense.aspx#vc2005intellisense_topic6
    http://msdn2.microsoft.com/fr-fr/library/ms364071(VS.80).aspx

     

    Different from 2003, 2005 intellisense starts to parse the system headers. If you use external system, you need to set  "Include Directories", etc for your system headers so that the intellisense engine can complete the parsing.

     

    Li Shao

    Visual C++ IDE

    Monday, February 25, 2008 5:20 AM
  • I tried to add system headers in the Include directories, but it did not solve the problem.

     

    Tuesday, February 26, 2008 12:17 AM
  • Here is one trouble shooting approach that you can try:

     

    1. Set environment variable: FEACP_LOG_OPTIONS to point to a txt file such as c:\intellisense.log

    2. Delete the NCB file for the project and reload the project

    3. Repro the operation where intellisense failed

     

    You may let us know the content of the log file and we can see if there is some header files missing.

     

    Li Shao

    Visual C++ IDE

    Tuesday, February 26, 2008 6:11 AM
  • I had this same problem today with VS 2005, using a project just for editing purposes but with no makefile or any intention of building with the project.  To get the autocomplete / intellisense to work for an include file you have to add the include directory to the project.

     

    right click and go to Properties on the top level of the project, then select Configuration Properties / C/C++ / General.

     

    The top entry there will be "Additional include directories"   Add any additional include directories there for you includes that don't seem to be getting parsed.  

     

    Hope that helps, worked for me.

     

    -Matt

    Tuesday, February 26, 2008 9:40 PM
  • devenv /ResetSkipPkgs will enable intellisense.

    Cheers,

    Mani

    • Proposed as answer by MikeBzzz Friday, March 4, 2016 11:22 AM
    Tuesday, December 25, 2012 2:06 PM