none
problem in visual studio 2017 c++ RRS feed

  • Question

  • hi there, excuse me please help me when i do run in visual studio 2017, show me ( the cod execution proceed because MSVCP100D.dll was not found. reinstalling the program may fix this problem.  

    and i download this file and put it in  "C:\Windows\sysWOW64"  still same problem

    Friday, June 14, 2019 1:04 AM

All replies

  • Hi hussien,

    Welcome to MSDN forum.

    As far as I know, the MSVCP100d.dll is similar with MSVCP100.dll, it also helps debugging your program. So please download and install this package from this page. Then clean and re-build your project.

    And if this issue persists, please follow the suggestions below:

    ## Please right-click project to open properties, then select C/C++ >> Code Generation, change Runtime Library to Multi-threaded Debug (/MTd)

    ## reinstall visual studio

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com



    Friday, June 14, 2019 8:32 AM
  • MSVCP100D.dll is the debug version of the VS 2010 Standard C++ library dll.

    It is not redistributable and is not included in any available download of VS2010 redistributables.

    Ordinarily, code you write using VS2017 would not need this dll.  If you installed VS2017 on a system where VS2010 was previously installed and are building with VS2010's toolset then the dll would already be on your system.

    Download and using this dll from any other source is problematic.

    Are you using third party libraries that require this dll?


    Friday, June 14, 2019 9:41 AM
  • Hi RLWA32,

    Thank you for pointing out this error.

    I confuse MSVCP100d.dll and MSVCP100.dll, and I have corrected the reply.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, June 14, 2019 10:26 AM
  • Hi hussien ismael,

    Does your issue is solved or not? If not, could you please share the detail error message when you build the code?

    If you already found the solution, please share it in here or mark the helpful reply, that will help other community members, we can also close this thread for you, thanks for your understanding.

    Best Regards,

    Dylan



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, June 19, 2019 11:25 AM