none
Stop Visual Studio launching debug when external program crashes RRS feed

  • Question

  • Hi,

    I'm running DosBox to play some old games and sometimes DosBox crashes or throws an error.
    When this happens VS launches to try and debug the problem.

    How do I stop this from happening, I just want DosBox to handle its own errors.

    Thanks Vlad

    PS only used VS a couple of times so not very familiar with it.
    Wednesday, May 23, 2007 5:56 PM

Answers

All replies

  • Hi,  Vlad

    In Visual Studio, Tools > Options... > Debugging (node) > Just-In-Time (child node), Uncheck all.

    Otherwise, see this thread: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=274145&SiteID=1

    Thanks

    Friday, May 25, 2007 6:00 AM
  • Cheers Figo, unchecked the above options in VS, then got this error instead

    "An unhandled win32 exception occurred in dosbox.exe [3568]. Just-In-Time debugging this exception failed with the following error: No installed debugger has Just-In-Time debugging enabled."

    After looking at the other thread decided to try setting this reg key from 1 to 0:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

    This stopped VS from trying to debug DosBox when it crashed.

    Don't know if this affects when you are using VS when programming?

    If it does then it's pretty easy to change the key back as long as I remember it was done.
    Friday, May 25, 2007 9:27 AM
  • Don't know if this affects when you are using VS when programming?

    The answer is "no".

    It only change the debugger setting.

    Thanks

     

    Friday, May 25, 2007 9:46 AM