none
Can't start debugger in VS2012 RC

    Question

  • Configuration:

    • Windows 7, 64 bit
      Microsoft Visual Studio Professional 2012 RC
      Version 11.0.50522.1 RCREL
    • Running VS in administrator mode
    • The VS solution contains a web application, with target: .NET Framework 4.

    When I press F5, the solution builds... and nothing else happens.  

    • Happens with both IIS or the VS Dev Server.
    • Happens with Platform Target of "Any CPU" or "x86"

    If instead, I use the Debug / Attach to Process... menu, after a few seconds, I get:

    1. "Debugger is Busy" - Debugger is performing a remote operation that is taking longer than expected.
    2. This dialog stay until I click "Terminate" and confirm it.
    3. Then this dialog appears:
      "Microsoft Visual Studio"
      "Unable to connect to the Microsoft Visual Studio Remote Debugging Monitor named [COMPUTER NAME]. The network connection to the Visual Studio Remote Debugger has been closed."
    4. After clicking OK, the 'normal' "Attach to Process" window finally shows up. In it, the list of "Available Processes" is empty.

    Any suggestions or clues?

    The main points that I wonder about:

    • Why is the list of processes empty?  It is not surprising that the debugger does not work if it cannot see any processes.
    • Why is it trying to do "remote" debugging, when it is just accessing the local computer?

    (Cross posted on stackoverflow)

    • Edited by Glen Little Sunday, June 24, 2012 4:16 PM add cross posting link
    Sunday, June 24, 2012 4:09 PM

Answers

All replies

  • Hi Glen,

    Thank you for posting in the MSDN forum.

    Whether others project has the same behavior? If they have the same issue, I’m afraid that it is the VS issue.

    You could locate to the IDE folder then run these commands, or you can set path to the system environment.

    C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    After these, you can create a new project in a new workspace to avoid if there’re any problems of the old workspace settings.

    If this issue is also exists, I think you need to reinstall the VS.

    If just the web app has this issue, could you share us a simple sample? We will try to debug it. Please attach your Visual Studio project, you can upload it to the sky driver, and then share the download link in your post.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, June 25, 2012 8:49 AM
    Moderator
  • Hi,

    same here. Single C# WPF-Project in the solution.  Suddenly Debugger not starting anymore. Rebuild, Clean makes no difference. Commandline switches change nothing.

    Best regards

    Klaus

    Wednesday, June 27, 2012 8:33 AM
  • Hi Klaus,

    Maybe you could try to restart you pc and reopen your VS and check it. If you create a simple app, does it work? If it works, I’m afraid that it is related to your app, you could try to create a new app and check it, or you could post your issue in the WPF forum for better support. If all apps didn’t work, I’m afraid that you would repair or reinstall your VS.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, June 28, 2012 5:10 AM
    Moderator
  • Same thing just started happening to me yesterday.

    It doesn't matter what project it is, or even if it's a completely new one.

    Both "Start" and "Attach to Process" pops up with "Debugger is performing a remote operation that is taking longer than expected.", which never ends.

    Restarting the computer, or resetting all settings has no effect.

    devenv.exe /setup has no effect either.

    Friday, June 29, 2012 5:00 PM
  • I've given up trying to work with VS 2012 RC for now...  using VS 2010.
    Friday, June 29, 2012 5:49 PM
  • Hi Glen,

    I have had the same problem with the Debugger in VB, C# and the C++ projects. But I am finding out the problem:

     1-      I gave free the MSVSMON.EXE in Windows 7 firewall

    2-       Setting for the Target-Platform, it is very important, it must be setting to x86 or x64 not an Any CPU.

    Kind regards


    • Edited by TrueEngine Sunday, July 01, 2012 8:43 PM
    Sunday, July 01, 2012 8:43 PM
  • Thanks for TrueEngine’s help.

    Hi Glen,

    I've given up trying to work with VS 2012 RC for now...  using VS 2010.

    Sine you will use the VS2010, so I will close this thread and make your reply as the answer, if you still need the help, please feel free to let us know.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, July 02, 2012 1:57 AM
    Moderator
  • Ultimately, a Repair of VS2012 resolved this issue for me.  I followed the advice found here without any resolution (Devenv.exe /SafeMode /ResetSettings /ResetSkipPkgs and /Setup).  Like the OP, my solution (VS 2010 SP1) also has a web application (targeting .NET 3.5), and the startup project is set to a winforms app.  The ASP.NET development server did not start, nor did the app I was trying to debug.

    Note that this issue was also posted to Connect at this link.  If anyone else sees this issue, the Connect folks are requesting running the Microsoft Visual Studio 2012 Feedback Tool to collect data. As I started the Repair process prior to finding the Connect issue, I did not and was not able to provide feedback with logging.

    And really, Jack, you think that "Using VS2010" is a viable answer to this topic?  Perhaps if there is no viable answer, one should not mark anything as an answer.  It really makes topics with answers completely non-helpful.

    Tuesday, July 10, 2012 11:46 AM
  • I'm having this same issue. Is there any solution to this?
    Tuesday, December 18, 2012 6:09 PM
  • I'm having this same issue. Is there any solution to this?
    What have you tried to resolve it?  Did you follow my link to the connect issue in the post above yours?  There are three listed workarounds posted there to try.
    Tuesday, December 18, 2012 6:16 PM
  • Just to provide an update... when I did install VS2012 RTM, the problem went away and hasn't been an issue since.
    • Edited by Glen Little Tuesday, December 18, 2012 8:18 PM add RTM
    Tuesday, December 18, 2012 8:17 PM
  • Hello microsoft. I cannot start debug anymore. the green play icon changed to 'Attach...' itself without i detect it. Can anyone help me with this???

    Wednesday, September 11, 2013 10:19 AM