none
localhost in WCF File upload RRS feed

  • Question

  • Hi, 

      I just start WCF to create a WCF file upload. I follow this one, it works if I run server and client on my machine. then I move all client code to another machine, 

    I change code in app.config

          <endpoint address="http://localhost:8100/FileTransfer" 

          to 

          <endpoint address="http://2UA9490W3D:8100/FileTransfer" 

    which 2UA9490W3D is my server machine name. it would not working. 

     

    What's the problem? What's the best way to do it? 

     

     

    thank you, 

    Wes

     


    Wes
    Thursday, June 9, 2011 8:03 PM

Answers

  • Hi wesbird,

     

    If the same service URI is working on your local box then I think you need to put IP of server instead of 2UA9490W3D.

    Please try

    And also share error that you are facing.

     

    Thanks

    Vikram

    • Marked as answer by wesbird Friday, June 10, 2011 6:47 PM
    Friday, June 10, 2011 12:18 AM

All replies

  • On 6/9/2011 4:03 PM, wesbird wrote:
    > Hi,
    >
    > I just start WCF to create a WCF file upload. I follow this one
    > <http://weblogs.asp.net/cibrax/archive/2007/08/29/sending-attachments-with-wcf.aspx>,
    > it works if I run server and client on my machine. then I move all
    > client code to another machine,
    >
    > I change code in app.config
    >
    > <endpoint address="http://localhost:8100/FileTransfer"
    >
    > to
    >
    > <endpoint address="http://2UA9490W3D:8100/FileTransfer"
    >
    > which 2UA9490W3D is my server machine name. it would not working.
    >
    > What's the problem? What's the best way to do it?
    >
    > thank you,
    >
     
    Well, if the machine hosting the service has a firewall enabled, then
    the firewall is blocking the inbound ports to any solicitation of
    communications with the service from the client.
     
    Thursday, June 9, 2011 8:08 PM
  • I cannot turn off the firewall due to the company policy, but I do add port exception for those ports I used (5000/8100/...). 

     

     

    Thanks, 


    Wes
    Thursday, June 9, 2011 8:16 PM
  • Hi wesbird,

     

    If the same service URI is working on your local box then I think you need to put IP of server instead of 2UA9490W3D.

    Please try

    And also share error that you are facing.

     

    Thanks

    Vikram

    • Marked as answer by wesbird Friday, June 10, 2011 6:47 PM
    Friday, June 10, 2011 12:18 AM
  • IP address works, 

     

    Thank you, 

    Wes


    Wes
    Friday, June 10, 2011 6:47 PM