none
Problem with displaying Georgian text in Console Application Visual Studio 2015 RRS feed

  • Question

  • Good day!

    In Visual Studio 2015, in the console window, instead of Georgian text, it displays such incomprehensible characters, while the Russian text is displayed correctly.

    Please advise how you can solve this problem.

    link attached: https://b.radikal.ru/b21/1910/01/f46e393443b4.jpg

    Thank you in advance!




    • Edited by EdZv Wednesday, October 30, 2019 10:46 AM
    Wednesday, October 30, 2019 10:44 AM

Answers

  • Thanks for answering Dylan!
    I noticed that my command "Console.OutputEncoding = System.Text.Encoding.UTF8" is in the wrong place inserted like yours.
    I did as you advised. In the properties of the Console, I chose the font "SimSun EXTB". As a result, the Georgian text was displayed but the letters merged in some places. 


    I had to download another monospaced font "DEJAVU SANS MONO" with Unicode support. This option turned out to be successful!


    As a result, it helped me:

    1. Your Code: "Console.OutputEncoding = System.Text.Encoding.UTF8";
    2. Installation of a monospace font "DEJAVU SANS MONO" and its selection in the Console properties (To select it in the console properties, first I had to add it to the registry).


    Many thanks to you and everyone who participated in the discussion of this topic!



    • Marked as answer by EdZv Tuesday, November 5, 2019 10:24 AM
    • Edited by EdZv Tuesday, November 5, 2019 11:18 AM
    Tuesday, November 5, 2019 10:00 AM

All replies

  • Now here is an interesting and fun experiment to do, those "incomprehensible" characters, select them in the console and copy them, then paste them back in the Visual Studio text editor. What do you get in Visual Studio when you paste? Do you get the Georgian characters?

    If you check the console properties, you should find what font the console is using:

    If you then check the character map for this font then you should find that there is no fonts defined for the Georgian range (U+10A0 - U+10FF).

    Notice how Character Map goes from U+0E3F to U+1D00? This "incomprehensible character" is the Unicode replacement character, the character that Windows displays when the font doesn't have any glyphs for the characters you want to display.

    Basically you need to get a monospace true type font that has the Georgian range and then change your console window's font to that. It will then display the Georgian text.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.

    Wednesday, October 30, 2019 4:56 PM
  • Hi EdZv,

    Welcome to the MSDN forum.

    According to your issue, if you want to output other languages on the console, you need to modify the code page to the corresponding language. But I found that the code page identifier that Microsoft supports doesn't seem to have a Georgian language.

    You can check this:https://docs.microsoft.com/en-us/windows/win32/intl/code-page-identifiers?redirectedfrom=MSDN

    BTW, you can suggest a feature to VS Product Team by Help-->Seed Feedback-->Suggest a Feature

    Maybe it can help you.

    Best Regards,

    Perry



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, October 31, 2019 7:10 AM
  • Hi EdZv,

    You could switch the font of console to "SimSun EXTB", then it could display Georgian text.

    Please right-click console when you debugging, then select Font, and change Font to "SimSun EXTB".

    Hope it could help you.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, November 1, 2019 8:28 AM
  • Hi EdZv,

    Did you have a try to modify console properties? Please follow my previous reply to change Font to "SimSun EXTB", and it works for me.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, November 5, 2019 9:11 AM
  • 

    Thanks for answering Perry.
    I went to the link that you sent. I found there "65001 utf-8 Unicode (UTF-8)"
    UTF8 encoding supports Georgian language.



    • Edited by EdZv Tuesday, November 5, 2019 10:10 AM
    Tuesday, November 5, 2019 9:13 AM
  • Thank you Darran Rowe for responding!
     1.  I did as you advised, I copied this text from the Console in a Visual Studio text editor. The text there is also displayed incorrectly. On the Russian-language forum, it was advised to insert the command "Console.OutputEncoding = System.Text.Encoding.UTF8"
    But that didn't help either.

    2. I installed a monospace font that supports Georgian, and in the properties of the Console I specified this font, it still displays incorrectly. I did the same for CMD Windows and there Georgian text is displayed correctly.


    • Edited by EdZv Tuesday, November 5, 2019 10:06 AM
    Tuesday, November 5, 2019 9:18 AM
  • Thanks for answering Dylan!
    I noticed that my command "Console.OutputEncoding = System.Text.Encoding.UTF8" is in the wrong place inserted like yours.
    I did as you advised. In the properties of the Console, I chose the font "SimSun EXTB". As a result, the Georgian text was displayed but the letters merged in some places. 


    I had to download another monospaced font "DEJAVU SANS MONO" with Unicode support. This option turned out to be successful!


    As a result, it helped me:

    1. Your Code: "Console.OutputEncoding = System.Text.Encoding.UTF8";
    2. Installation of a monospace font "DEJAVU SANS MONO" and its selection in the Console properties (To select it in the console properties, first I had to add it to the registry).


    Many thanks to you and everyone who participated in the discussion of this topic!



    • Marked as answer by EdZv Tuesday, November 5, 2019 10:24 AM
    • Edited by EdZv Tuesday, November 5, 2019 11:18 AM
    Tuesday, November 5, 2019 10:00 AM