none
DOM Explorer Automatic Highlighting

    Question

  • Hello Everyone!

    I've been searching for how to disable this feature and have had absolutely zero luck so I figured I'd ask here.

    Unfortunately I'm not sure what this function is called so I'll be describing it. 

    When you're debugging a web based project and are in the DOM explorer of IE/edge and you highlight an element to see its properties visual studio will automatically go to and highlight that element in the source code. 

    Is there a way to disable this? I've looked through the debug settings trying to find out what this is because I find it extremely annoying. 

    Any help would be sincerely appreciated! 

    Thanks for your time :) 

    Monday, January 30, 2017 4:39 PM

All replies

  • Hi Seriously_Casual,

    Which version of Visual Studio do you use?

    I'm using Visual Studio Community 2015 and it doesn't hightlight the element source code in Visual Studio automatic when I selected it in IE DOM Explorer window. When I select the element in DOM Explorer, it only highlighted in DOM Explorer window.

    In addition, please try reset your Visual Studio settings through Tools -> Import and Export settings -> Reset all settings. Before resetting, please backup your Visual Studio settings first.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 1, 2017 2:36 AM
  • Thanks for your response!

    I'm using Visual Studio 2015 Professional. Two of my co-workers who are also using the product experience this behavior as well. 

    I tried resetting my settings back to default and unfortunately that did not stop the behavior. 

    Wednesday, February 1, 2017 1:09 PM
  • Hi Seriously_Casual,

    I get the same result in Visual Studio 2015 Enterprise. And I checked all debug settings in Visual Studio 2015, I don't found a setting could disable this feature.

    So I help you submit this issue to Visual Studio UserVoice. Please add your comments and vote this feedback. I think the report team will treat this issue seriously.

    https://visualstudio.uservoice.com/forums/121579-visual-studio-ide/suggestions/17931490-disable-dom-explorer-automatic-highlighting

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, February 3, 2017 2:00 AM