none
About problems in the VS build process in the Face Behavior Analysis Toolkit RRS feed

  • Question

  • 严重性 代码 说明 项目 文件 禁止显示状态
    错误 MSB3073 命令“xcopy /I /E /Y /D "F:\大创二\OpenFace-master_new\OpenFace-master\lib\local\LandmarkDetector\model" "F:\大创二\OpenFace-master_new\OpenFace-master\x64\Release\model"
    xcopy /I /E /Y /D "F:\大创二\OpenFace-master_new\OpenFace-master\lib\3rdParty\OpenCV\classifiers" "F:\大创二\OpenFace-master_new\OpenFace-master\x64\Release\classifiers"
    :VCEnd”已退出,代码为 9009。 LandmarkDetector C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets 138 \

    严重性 代码 说明 项目 文件 禁止显示状态
    错误 MSB3073 命令“xcopy /I /E /Y /D /C "F:\大创二\OpenFace-master_new\OpenFace-master\lib\3rdParty\OpenCV\x64\v141\bin\Release" "F:\大创二\OpenFace-master_new\OpenFace-master\x64\Release\"
    xcopy /I /E /Y /D /C "F:\大创二\OpenFace-master_new\OpenFace-master\lib\3rdParty\OpenCV\bin\opencv_ffmpeg410.dll" "F:\大创二\OpenFace-master_new\OpenFace-master\x64\Release\"
    xcopy /I /E /Y /D /C "F:\大创二\OpenFace-master_new\OpenFace-master\lib\3rdParty\OpenCV\bin\opencv_ffmpeg410_64.dll" "F:\大创二\OpenFace-master_new\OpenFace-master\x64\Release\"
    xcopy /I /E /Y /D /C "F:\大创二\OpenFace-master_new\OpenFace-master\lib\3rdParty\OpenCV\classifiers" "F:\大创二\OpenFace-master_new\OpenFace-master\x64\Release\classifiers"
    :VCEnd”已退出,代码为 9009。 Utilities C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets 138


    Thursday, October 3, 2019 7:49 PM

All replies

  • Hi Liuxuyang,

    Welcome to MSDN forum.

    According to the log, the xcopy cannot copy the file to destination directory, it seems that the related files and folders don't exist, so please check it on your machine. 

    And we recommend you could build project using Build/build solution, it would automatically generate your project in the desired order.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, October 4, 2019 2:32 AM
  • Hi Liuxuyang,

    Did your issue still persist? How did you build your project?

    Did you add the copy command in the build event of the project properties or in the proj file?

    In general, we add your command into the post-build event(right-click your project in VS IDE-->Properties-->Build Event-->Post-Build Event)

    > >make sure that both input and output addresses exist and can be operated and make sure that all the " is English form and is consistent.

    ##Then you can click Build and it will run without any error.

    If it does not work, please share the specific steps,the proj file and any other useful information for better help. If you do not use VS to build project, please share the detailed information.

    Any feedback will be expected.

    Best Regards,

    Perry



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Tuesday, October 8, 2019 4:53 AM
  • Hi friend,

    Any update for this issue?

    1.As I know the exited code 9009 always means `the command can not recognized by cmd.exe`. But xcopy command is recognized in Windows OS in most cases, so there might be something wrong with your command format defined in Build events . I suggest you can run the xcopy command in cmd.exe first, it it runs well, then move those commands into VS.

    2.According to this issue we can find sometimes this issue will occurs when VS lose the path to xcopy, so for VS it's a command which can't be recognized. You can follow the suggestions in that similar issue to resolve that.

    In addition: For more details about what code9009 means, please refer to similar issue here.

    Hope it helps. And if it's helpful or not to resolve your issue, please feel free to let me know :)

    Have a good day!

    Best Regards

    Lance


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, October 15, 2019 9:16 AM