none
Microsoft Office Interop Excel RRS feed

  • Question

  • Please, I´m using VS 2010, .NET Framework 4.0 and Microsoft.Office.Interop.Excel version 15.

    My app will be deployed for users that have Excel 2007, 2010 or 2013.

    In the Properties, EMBED INTEROP TYPES is set to TRUE.

    And SPECIFIC VERSION, how should be set?  

    Thanks.

    Friday, July 24, 2015 2:26 PM

Answers

All replies

  • Hello,

    Here are the instructions to follow

    https://msdn.microsoft.com/en-us/library/ee317478.aspx?f=255&MSPPError=-2147217396#Y726


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my webpage under my profile but do not reply to forum questions.

    Friday, July 24, 2015 3:31 PM
    Moderator
  • Also, the app should be developed using the minimum supported version. If you develop in 2013 you run the risk of the app breaking when running under 2007.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Friday, July 24, 2015 3:54 PM
  • So I will  use Interop version 14.0.

    But what is the meaning of the property SPECIFIC VERSION? It can be set to TRUE or FALSE....

    Friday, July 24, 2015 4:23 PM
  • Hi,

    "Specific Version" is a build-time property directing the compiler to use the available version.  At run-time, the framework still looks for the specific version of the assembly that was used at build time.

    you could check this: http://stackoverflow.com/a/24022135

    Wednesday, July 29, 2015 2:55 AM
  • So I will  use Interop version 14.0.

    But what is the meaning of the property SPECIFIC VERSION? It can be set to TRUE or FALSE....


    See the below link. It should help you decide whether to set this property to True.

    http://blogs.msdn.com/b/irenak/archive/2005/12/13/503105.aspx


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Wednesday, July 29, 2015 1:47 PM