none
Visual Studio Crashing/Restarting Every Hour RRS feed

  • Question

  • I'm running Visual Studio Professional 2015 Version 14.0.23107.0.D14REL
    I am also running Windows 10

    VS2015 crashes/restarts every hour starting from the time that I launch it, even when I am not working on it. If I just start VS2015 and leave it alone it will crash/restart an hour later and every hour thereafter. 


    I am also running VS2015 in SAFE MODE when this happens. 


    I found a pair of errors in my Event Log. Turns out they are always in pairs when this happens. I just can't make out what this means. I think I've googled just about everything on this and find nothing related to what I'm experiencing. Any advise would be greatly appreciated.

    FIRST ERROR LOG ENTRY

    .NET Runtime EventID 1026 - System - Provider [ Name] .NET Runtime - EventID 1026 [ Qualifiers] 0 Level 2 Task 0 Keywords 0x80000000000000 - TimeCreated [ SystemTime] 2015-08-28T22:07:08.000000000Z EventRecordID 14935 Channel Application Computer mdad Security - EventData

    Application: devenv.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.UnauthorizedAccessException Stack: at System.Runtime.CompilerServices.AsyncMethodBuilderCore+<>c__DisplayClass2.b__5(System.Object) at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object) at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() at System.Threading.ThreadPoolWorkQueue.Dispatch() at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

    SECOND ERROR LOG ENTRY

    System
    Provider [ Name] Application Error
    EventID 1000 [ Qualifiers] 0 Level 2 Task 100 Keywords 0x80000000000000
    TimeCreated [ SystemTime] 2015-08-28T22:07:08.000000000Z EventRecordID 14936 Channel Application Computer mud-dad Security
    EventData devenv.exe 14.0.23107.0 559b7ead KERNELBASE.dll 10.0.10240.16384 559f3b2a e0434352 000b3e28 4330 01d0e1d57b904f45 C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe C:\WINDOWS\SYSTEM32\KERNELBASE.dll 9ead8f6c-f423-49a1-aa5a-937c1bfde37e

    Any ideas? 


     



    • Edited by XPacheco Saturday, August 29, 2015 6:49 PM Claified
    Friday, August 28, 2015 10:34 PM

Answers

  • Hi XPacheco,

    Please take the following steps to troubleshoot this issue:

    (1) Clear the ComponentModelCache folder

    Delete or rename this folder: %AppData%\..\Local\Microsoft\VisualStudio\14.0\ComponentModelCache

    And then restart visual studio.

    (2) Check to see if any extensions need updates and update them first to see if that fixes your problem. Please go to Tools -> Extensions and Updates to check.

    (3) disable all add-ins and extensions, please go to Tools -> Add-in Manager to disable them.

    (4) uninstall all plugins

    (5) Reset vs settings, Please open Windows Explorer, and navigate to  <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files \Microsoft Visual Studio 14.0\Common7\IDE), and run the following commands:

    a.devenv.exe /resetskippkgs, it will clear all SkipLoading tags that have been added to VSPackages by users who want to avoid loading problem VSPackages.
    b.devenv.exe /resetsettings, it will restore Visual Studio default settings. Optionally resets the settings to the specified .vssettings file.
    c.devenv.exe /resetuserdata, it will take a couple of minutes to run as Visual Studio cleans up and sets itself back to its original state. You may open Task Manager at this point to check whether the devenv.exe process is still running. After it has completed running, you can restart Visual Studio.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, August 31, 2015 8:43 AM
    Moderator

All replies

  • I'm running Visual Studio Professional 2015 Version 14.0.23107.0.D14REL
    I am also running Windows 10

    VS2015 crashes/restarts every hour starting from the time that I launch it, even when I am not working on it. If I just start VS2015 and leave it alone it will crash/restart an hour later and every hour thereafter. 

    I am also running VS2015 in SAFE MODE when this happens. 

    I found a pair of errors in my Event Log. Turns out they are always in pairs when this happens. I just can't make out what this means. I think I've googled just about everything on this and find nothing related to what I'm experiencing. Any advise would be greatly appreciated.

    FIRST ERROR LOG ENTRY

    .NET Runtime EventID 1026 - System - Provider [ Name] .NET Runtime - EventID 1026 [ Qualifiers] 0 Level 2 Task 0 Keywords 0x80000000000000 - TimeCreated [ SystemTime] 2015-08-28T22:07:08.000000000Z EventRecordID 14935 Channel Application Computer mdad Security - EventData

    Application: devenv.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.UnauthorizedAccessException Stack: at System.Runtime.CompilerServices.AsyncMethodBuilderCore+<>c__DisplayClass2.b__5(System.Object) at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object) at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() at System.Threading.ThreadPoolWorkQueue.Dispatch() at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

    SECOND ERROR LOG ENTRY

    System
    Provider [ Name] Application Error
    EventID 1000 [ Qualifiers] 0 Level 2 Task 100 Keywords 0x80000000000000
    TimeCreated [ SystemTime] 2015-08-28T22:07:08.000000000Z EventRecordID 14936 Channel Application Computer mud-dad Security
    EventData devenv.exe 14.0.23107.0 559b7ead KERNELBASE.dll 10.0.10240.16384 559f3b2a e0434352 000b3e28 4330 01d0e1d57b904f45 C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe C:\WINDOWS\SYSTEM32\KERNELBASE.dll 9ead8f6c-f423-49a1-aa5a-937c1bfde37e

    Any ideas? 

     

    Saturday, August 29, 2015 6:52 PM
  • Hi,

    To make sure whether it is related to the add-ins, Please open Windows Explorer, and navigate to  <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files \Microsoft Visual Studio 14.0\Common7\IDE), and then run the following command:

    Devenv.exe /SafeMode, This can eliminate the possibility that third party Add-ins or packages are causing problems. Thus ensuring stable execution.

    If in SafeMode, VS doesn't crash, it is related to the add-ins, please go to Tools -> Add-in Manager, disable the add-ins.

    Refer :https://social.msdn.microsoft.com/Forums/vstudio/en-US/8e2af53b-a3a0-4d2b-bd9a-0251620f57b0/visual-studio-2015-community-keeps-crashing?forum=visualstudiogeneral

    Thanks
    Abhishek

    Saturday, August 29, 2015 7:54 PM
  • Hi, Abhishek,

     Thank you for the reply.  VS2015 is indeed running in Safe Mode.  In fact, Safe Mode is specified on the Window Title ("Microsoft Visual Studio - Safe Mode"). 


    Saturday, August 29, 2015 8:22 PM
  • Hi XPacheco,

    Please take the following steps to troubleshoot this issue:

    (1) Clear the ComponentModelCache folder

    Delete or rename this folder: %AppData%\..\Local\Microsoft\VisualStudio\14.0\ComponentModelCache

    And then restart visual studio.

    (2) Check to see if any extensions need updates and update them first to see if that fixes your problem. Please go to Tools -> Extensions and Updates to check.

    (3) disable all add-ins and extensions, please go to Tools -> Add-in Manager to disable them.

    (4) uninstall all plugins

    (5) Reset vs settings, Please open Windows Explorer, and navigate to  <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files \Microsoft Visual Studio 14.0\Common7\IDE), and run the following commands:

    a.devenv.exe /resetskippkgs, it will clear all SkipLoading tags that have been added to VSPackages by users who want to avoid loading problem VSPackages.
    b.devenv.exe /resetsettings, it will restore Visual Studio default settings. Optionally resets the settings to the specified .vssettings file.
    c.devenv.exe /resetuserdata, it will take a couple of minutes to run as Visual Studio cleans up and sets itself back to its original state. You may open Task Manager at this point to check whether the devenv.exe process is still running. After it has completed running, you can restart Visual Studio.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, August 31, 2015 8:43 AM
    Moderator
  • This does not work for me. :(

    Any other progress on this issue?

    Regards

    Tuesday, October 13, 2015 5:18 AM