none
SSDT for Visual Studio 2017 (Error) RRS feed

  • Question

  • Hi,

    I'm having issues installing SSDT 15.3 Preview for Visual Studio 2017 Professional. All the articles I've read mention that this version should be compatibe with the latest version of Visual Studio.

    Error code is 0x80070643 and the log file show the following...

    [1E70:24C8][2017-09-15T11:45:19]e000: Error 0x80070643: Process returned error: 0x643
    [1E70:24C8][2017-09-15T11:45:19]e000: Error 0x80070643: Failed to execute EXE package.
    [25F8:22AC][2017-09-15T11:45:19]e000: Error 0x80070643: Failed to configure per-machine EXE package.
    [25F8:22AC][2017-09-15T11:45:19]i000: MainViewModel.OnPackageAction: Install Completed for package SQL Server Analysis Services (id: Microsoft.DataTools.AnalysisServices)
    [25F8:22AC][2017-09-15T11:45:19]i319: Applied execute package: Microsoft.DataTools.AnalysisServices, result: 0x80070643, restart: None
    [25F8:22AC][2017-09-15T11:45:19]e000: Error 0x80070643: Failed to execute EXE package.
    [1E70:24C8][2017-09-15T11:45:19]i351: Removing cached package: Microsoft.DataTools.AnalysisServices, from path: C:\ProgramData\Package Cache\9864EE5369359DB622D0234B6C6B7640B949140C\
    [25F8:22AC][2017-09-15T11:45:19]i000: MainViewModel.OnPackageActionProgress: Percent completed: 100, Overall progress: 100
    [1E70:24C8][2017-09-15T11:45:19]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{5d5d6235-5c8c-4377-9a75-1b6368850657}, resume: None, restart: None, disable resume: No
    [1E70:24C8][2017-09-15T11:45:19]i330: Removed bundle dependency provider: {5d5d6235-5c8c-4377-9a75-1b6368850657}
    [1E70:24C8][2017-09-15T11:45:19]i352: Removing cached bundle: {5d5d6235-5c8c-4377-9a75-1b6368850657}, from path: C:\ProgramData\Package Cache\{5d5d6235-5c8c-4377-9a75-1b6368850657}\
    [1E70:24C8][2017-09-15T11:45:19]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{5d5d6235-5c8c-4377-9a75-1b6368850657}, resume: None, restart initiated: No, disable resume: No
    [25F8:22AC][2017-09-15T11:45:19]e000: MainViewModel.OnBundleAction: Bundle action failed: Fatal error during installation (0x80070643)
    [25F8:22AC][2017-09-15T11:45:19]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart:  No

    Any suggestions as to how to resolve this would be greatly appreciated as it is holding up my project.

    Thanks in advance.

    Friday, September 15, 2017 10:52 AM

All replies

  • Hi AdzG,

    Thank you for posting in MSDN forum.

    Error code 0x80070643 usually means that the packages are not complete and broken. Please clean the %Temp% folder,  check and install all the windows update. Reboot your machine, disable all the AV software and firewall to perform a new SSDT installation from Download SQL Server Data Tools .

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Chrismit Monday, October 15, 2018 6:04 PM
    Monday, September 18, 2017 8:37 AM
    Moderator
  • I'm also getting that same error for the Analysis package - and just did a /layout download 30 minutes ago.
    Monday, September 18, 2017 1:54 PM
  • Make sure to un-install the SSRS and SSAS packages from Visual Studio before installing.
    Monday, September 18, 2017 2:00 PM
  • I got the same error and saw this post after bing-ing.

    The problem with my installation was with VS2017. I had installed a trial version and the 30 days passed. So I just installed SQL Server Data Tools for VS2015 because my VS2015 is licensed and registered :)


    Computer is a box with magic called software.

    Monday, November 20, 2017 5:35 AM
  • I had the same errors - tried just about everything mentioned here and elsewhere (clear temp, uninstall/reinstall VS2017), run as Admin, login as Admin and run, log in a new user...still the same errors at the 50% mark. That was my Saturday gone! Sunday - tried on my other Win 10 box (no development software installed)...installed VS2017 ok, installed SSDT 2017 ok - albeit one at a time with one reboot, so now can open my ssrs reports project at last, but have to rdc to the box to work.
    • Proposed as answer by kkoonnsstt Tuesday, June 12, 2018 4:57 PM
    Sunday, December 10, 2017 2:19 PM
  • Same here, I cannot get this to work either. It just will not install at all.
    Thursday, May 10, 2018 3:52 PM
  • Same here.. already struggling from 3days... my weekend is gone..

    tmrw i have to setup SSTD and show SSIS Packages Demo...

    will microsoft help me // i am ready to have remote sharing of my pc and proceed with the solution

    can i get the support team phone number.. 


    Paul

    Sunday, July 15, 2018 6:02 PM
  • clearing out windows/TEMP directory helped me.  thank you
    Monday, October 15, 2018 6:04 PM