none
Error - Could not write lines to file 'xxx.FileListAbsolute.txt' Access to the path denied

    Question

  • I'm getting the following error when running a Team Foundation Build 2008.

     

    C:\WINDOWS\Microsoft.NET\Framework\v3.5\Microsoft.Common.targets(3246,9): error MSB3491: Could not write lines to file "obj\Release\xxx.Common.vbproj.FileListAbsolute.txt". Access to the path 'c:\TFS Builds\Sources\Development\xxx.Common\obj\Release\xxx.Common.vbproj.FileListAbsolute.txt' is denied.

     

    The service account does have full access to the above build folder.  It is creating the othe files in that directory though.

    Any ideas?

     

    Thanks

    Paul

    Wednesday, April 30, 2008 2:21 PM

Answers

  • I was able to resolve this.  Those files should not have been added to TFS to begin with.  I deleted them and now can build successfully.

     

    Friday, May 02, 2008 3:57 PM

All replies

  • Sorry - no answer, but I'm having this exact same problem. 

     

    Friday, May 02, 2008 3:54 PM
  • I was able to resolve this.  Those files should not have been added to TFS to begin with.  I deleted them and now can build successfully.

     

    Friday, May 02, 2008 3:57 PM
  • Thank you!!!!

    • Proposed as answer by Luca Grillo Friday, August 30, 2013 9:07 AM
    Wednesday, May 28, 2008 10:48 AM
  • To elaborate:  You need to delete the contents of the obj directory for each project within the solution. Visual Studio 2008 seems to have a quark about not wanting to write to writable files.  I would suggest you remove the contents of these directories from TFS as suggested.

     

    Andy

     

    Thursday, June 19, 2008 6:21 PM
  • I had the same problem. The files had the read-only attribute set. This happened when i added the code to my source control. i just unchecked the read-only attribute on the parent directory and everything built just fine.

     

    Monday, July 28, 2008 4:31 PM
  • You d better not checkin OBJ and BIN folder in the source control. It happens to me as well. I just removed these two folder and it works.
    Tuesday, September 01, 2009 11:35 PM
  • Thanks for the Info

    I just made a quick serch for the " obj " and " bin" folders in my solution ( Physical path) and deleted them

    Bingo .......it worked like a charm
    Thursday, October 15, 2009 7:47 PM
  • Solution is simpler than deleting all the files. The reason VS is throwing this error is because these files are marked read only. It usually happens when you check your code out for the first time. Right click on the whole folder with project, click properties, remove read only flag and make sure you propagate changes to child folders. Works like a charm. ;)

    Tuesday, October 25, 2011 8:26 PM
  • I have the same problem to and tried to remove the "Read Only but just it remains the same.. Since I am beginner what do you mean by propogate changes ?

    Thanks

    Thursday, August 02, 2012 10:23 AM
  • Even I faced the same problem. It worked for me. Please delete the bin / obj folder and build the application.

    Wednesday, October 17, 2012 10:16 AM
  • I had the same problem. In same project, It can be ok when I deleted the bin folder and obj folder ,but in some project,I mast include the two folders in to project .
    Sunday, September 29, 2013 1:43 AM