none
Problems With Visual Studio And Management Studio Crashing RRS feed

  • General discussion

  • I have the following installed:

    Microsoft Visual Studio 2005 Version 8.0.50727.42
    Microsoft SQL Server Management Studio      9.00.1399.00
    Microsoft Analysis Services Client Tools      2005.090.1399.00
    Microsoft Data Access Components (MDAC)      2000.085.1117.00 (xpsp_sp2_rtm.040803-2158)
    Microsoft MSXML      2.6 3.0 4.0 5.0 6.0
    Microsoft Internet Explorer      7.0.5730.13
    Microsoft .NET Framework      2.0.50727.1433 SP1
    Operating System      5.1.2600


    Visual Studio and Mgt Studio frequently crash on me. The application stops and an error is generated by Windows Error Reporting. The messages I am receiving today include the following:

     

    Date: 9/2/2008

    Time: 10:08:20 AM

    Event Type: Error
    Event Source: .NET Runtime 2.0 Error Reporting
    Event Category: None
    Event ID: 5000
    User:  N/A

    Description:

    EventType clr20r3, P1 sqlwb.exe, P2 2005.90.1406.0, P3 45ea44e0, P4 system.drawing, P5 2.0.0.0, P6 471ebf30, P7 33a, P8 18, P9 amag3aacmawg2xaf344u21acve5pstkl, P10 NIL.

     

     

    Date: 9/2/2008

    Time: 11:20:37 AM

    Event Type: Error
    Event Source: Microsoft Visual Studio
    Event Category: None
    Event ID: 1000
    User:  N/A


    Description:

    Faulting application devenv.exe, version 8.0.50727.42, stamp 4333e699, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239bd5, debug? 0, fault address 0x00012a5b.




    Date: 9/2/2008

    Time: 11:22:24 AM

    Event Type: Error
    Event Source: Microsoft Visual Studio
    Event Category: None
    Event ID: 1000
    User:  N/A


    Description:

    Faulting application devenv.exe, version 8.0.50727.42, stamp 4333e699, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239bd5, debug? 0, fault address 0x00012a5b.

     

     

     

    Date: 9/2/2008

    Time: 11:23:13 AM

    Event Type: Error
    Event Source: Microsoft Visual Studio
    Event Category: None
    Event ID: 5000
    User:  N/A


    Description:

    EventType clr20r3, P1 devenv.exe, P2 8.0.50727.42, P3 4333e699, P4 NIL, P5 NIL, P6 NIL, P7 NIL, P8 NIL, P9 NIL, P10 NIL.

     

     

     

    Date: 9/2/2008

    Time: 11:23:22 AM

    Event Type: Error
    Event Source: .NET Runtime 2.0 Error
    Event Category: None
    Event ID: 1000
    User:  N/A


    Description:

    Faulting application devenv.exe, version 8.0.50727.42, stamp 4333e699, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239bd5, debug? 0, fault address 0x0000976f.

     

     

     

    Date: 9/2/2008

    Time: 11:30:52 AM

    Event Type: Error
    Event Source: Microsoft Visual Studio
    Event Category: None
    Event ID: 1000
    User:  N/A


    Description:

    Faulting application devenv.exe, version 8.0.50727.42, stamp 4333e699, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239bd5, debug? 0, fault address 0x00012a5b.

     

     

     

     

    Date: 9/2/2008

    Time: 11:33:20 AM

    Event Type: Error
    Event Source: Microsoft Visual Studio
    Event Category: None
    Event ID: 1000
    User:  N/A


    Description:

    Faulting application devenv.exe, version 8.0.50727.42, stamp 4333e699, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239bd5, debug? 0, fault address 0x00012a5b.



    Date: 9/2/2008

    Time: 11:36:59 AM

    Event Type: Error
    Event Source: Microsoft Visual Studio
    Event Category: None
    Event ID: 1000
    User:  N/A


    Description:

    Faulting application devenv.exe, version 8.0.50727.42, stamp 4333e699, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239bd5, debug? 0, fault address 0x00012a5b.

     

     

     

     

     

    Date: 9/2/2008

    Time: 11:37:07 AM

    Event Type: Error
    Event Source: .NET Runtime 2.0 Error
    Event Category: None
    Event ID: 5000
    User:  N/A


    Description:

    EventType clr20r3, P1 devenv.exe, P2 8.0.50727.42, P3 4333e699, P4 microsoft.reportingservices.diagnostics, P5 9.0.242.0, P6 45ea4e08, P7 9f6, P8 20, P9 tozijkhykofadfz3miequiyylmh0ubuj, P10 NIL.



     

    Date: 9/2/2008

    Time: 11:56:40 AM

    Event Type: Error
    Event Source: 
    Microsoft Visual Studio
    Event Category: None
    Event ID: 1000
    User:  N/A


    Description:

    Faulting application devenv.exe, version 8.0.50727.42, stamp 4333e699, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239bd5, debug? 0, fault address 0x00012a5b.

     


    How can I debug this problem?


    Bob
    • Changed type Figo Fei Monday, September 8, 2008 3:58 AM to comment
    Tuesday, September 2, 2008 6:37 PM

All replies

  • On which step, it crashes?
    Please launch the IDE into sofemode: devenv /safemode, is there any problem then?

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Thursday, September 4, 2008 2:47 AM
  • Since installing the VS2008 SP1 and .NET 3.5 updates, neither my VS2005 or VS2008 or BIDS will work.  I tried running devenv /safemode and VS2005 did load.  I would send the error report, but of course you cannot cut and paste from the error box.  Tell me how to collect the data you need and I will include.  Another wonderful Microsoft enhancement.
    Friday, September 12, 2008 7:44 PM
  • I also have the same problem here.

    Event Type: Error
    Event Source: .NET Runtime 2.0 Error Reporting
    Event Category: None
    Event ID: 1000
    Date:  09/29/2008
    Time:  3:56:45 PM
    User:  N/A
    Computer: SQL-SERVER
    Description:
    Faulting application sqlwb.exe, version 2005.90.3073.0, stamp 4898aa0e, faulting module unknown, version 0.0.0.0, stamp 00000000, debug? 0, fault address 0x800c0005.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 41 00 70 00 70 00 6c 00   A.p.p.l.
    0008: 69 00 63 00 61 00 74 00   i.c.a.t.
    0010: 69 00 6f 00 6e 00 20 00   i.o.n. .
    0018: 46 00 61 00 69 00 6c 00   F.a.i.l.
    0020: 75 00 72 00 65 00 20 00   u.r.e. .
    0028: 20 00 73 00 71 00 6c 00    .s.q.l.
    0030: 77 00 62 00 2e 00 65 00   w.b...e.
    0038: 78 00 65 00 20 00 32 00   x.e. .2.
    0040: 30 00 30 00 35 00 2e 00   0.0.5...
    0048: 39 00 30 00 2e 00 33 00   9.0...3.
    0050: 30 00 37 00 33 00 2e 00   0.7.3...
    0058: 30 00 20 00 34 00 38 00   0. .4.8.
    0060: 39 00 38 00 61 00 61 00   9.8.a.a.
    0068: 30 00 65 00 20 00 69 00   0.e. .i.
    0070: 6e 00 20 00 75 00 6e 00   n. .u.n.
    0078: 6b 00 6e 00 6f 00 77 00   k.n.o.w.
    0080: 6e 00 20 00 30 00 2e 00   n. .0...
    0088: 30 00 2e 00 30 00 2e 00   0...0...
    0090: 30 00 20 00 30 00 30 00   0. .0.0.
    0098: 30 00 30 00 30 00 30 00   0.0.0.0.
    00a0: 30 00 30 00 20 00 66 00   0.0. .f.
    00a8: 44 00 65 00 62 00 75 00   D.e.b.u.
    00b0: 67 00 20 00 30 00 20 00   g. .0. .
    00b8: 61 00 74 00 20 00 6f 00   a.t. .o.
    00c0: 66 00 66 00 73 00 65 00   f.f.s.e.
    00c8: 74 00 20 00 38 00 30 00   t. .8.0.
    00d0: 30 00 63 00 30 00 30 00   0.c.0.0.
    00d8: 30 00 35 00 0d 00 0a 00   0.5.....

    Does anyone the fix? Thank you in advance.


    airy airy
    Tuesday, September 30, 2008 4:02 PM
  • My issues were caused by the IBM DB2 add-in.  Seems it does not like the new service pack.  I tried to remove the add-in, but it would not uninstall due to not finding the original MSI file and it would not repair itself saying it could not find any VS templates.  There is a line command to reinstall the VS templates and tried this on VS2008.  Did not work.  Uninstalled VS2008 and deleted the IBM add-in from my machine.  Reinstalled everything without SP1.  got the same template errors on the reinstall.  Needed reinstall the templates on VS2005, not VS2008.  Bad previous assumption on my part.  Repair would probably have worked if I had fixed the templates in the correct environment.  From what I have found, these errors are most likely caused by issues with add-ins not liking the service pack.  If you can load in Safe Mode, then it is most likely an add-in issue.
    Tuesday, September 30, 2008 4:52 PM