none
.NET Framework 2.0 setup fails (Error 4123)

    Question

  •  

    I'm trying to install the .NET Framework v2.0 re-distributable on an embedded  WinXP SP2 system.  The setup program fails, saying the product is already installed as an operating system component.  However, there's nothing in the Add/Remove Programs, and when I check C:\WINDOWS\Microsoft.NET\Framework directory, there isn't a v2.0.50727 directory.  (.NET v1.1 is installed)

     

    Items of note from the .NET 2.0 Setup log:


    [03/16/08,10:54:49] Looking for: 2.0.0
    [03/16/08,10:54:49] Found: 3.1.4000

    <<SNIP>>
    [03/16/08,10:54:49] ***ERROR EVENT*** : SYSTEM CHECK: : OCM product installed  Failed

    <<SNIP>>
    [03/16/08,10:54:57] Process returning code 4123

     

    I found a blog entry that gave error codes for the .NET Setup program, and it says the following for the error code:
    0x00101B (4123) - The product is already installed as an operating system component (the .NET Framework 2.0 is an OS component on Windows Vista and installing the MSI-based setup is blocked and will return this error in silent mode)

     

    I've used the same setup program to install on other Embedded WinXP SP2 systems without any problems, so I don't think the setup is wrong or corrupt.

     

    Anyone seen this before?

     

    Thanks

     

    Sunday, March 16, 2008 7:14 PM

Answers

All replies

  • So can you see .NET 2.0 using Windows Installer CleanUp Utility ?

    You may also use Updated .NET Framework cleanup tool: http://blogs.msdn.com/astebner/archive/2007/12/04/6659905.aspx  to remove and install again.

     

    Thanks

    Tuesday, March 18, 2008 4:23 AM
  • I have the same problem... .NET Framework 2.0 does not show up in WIndows Installer CleanUp Utility.
    I have tried Aaron Stebner's .NET Cleanup Tool a few times but it doesn't fix the problem.
    Sunday, November 15, 2009 1:12 AM
  • Would this be the same thing causing .NET Framework 3.5 SP1... im guessing it is...
    grrrr....
    did i mention me and my computer have a love/hate relationship (mostly hate)
    HELP!!!!!!!
    Sunday, November 15, 2009 1:20 AM
  • Hi there,

    I get the same Error code 4123 described by AFuchigami above but I'm on Windows 7. This means that the Windows Installer CleanUp Utility doesn't apply to me. Also I understand .NET 2.0 is part of the operating system in Windows 7 and so..

    • Aaron Stebner's .NET Cleanup Tool does not clean up .NET 2.0 in Windows 7
    • .NET 2.0 doesn't appear in add/remove programs in Windows 7

    But I know my .NET 2.0 is corrupted because I get the following error code when trying to run an example exe (eg. Netfx20TestApplication.exe from Aaron Stebner's .NET verification tool):

    • exited with return code -2147010895

    How do I reinstall/repair it?
    Is it safe to delete all the files on the C drive and re-run the installer, or will that ruin my OS?

    Thanks,

    Ann


    Monday, May 7, 2012 12:30 PM