regsvr32 "load library failed"


  • Hey all. I'm trying to register an .ocx file on WinXP, but I get this message: "load library failed, the specified module could not be found". I was told I can use microsoft's Event Viewer to see what error I get when I fail to register, and by seeing this error's properties I will be able to see which dlls I might be missing. But I don't see any eror when I open the Event Viewer. Did anyone used this tool? Is there another way to find out what's wrong with the registration?

    Thanks a lot,


    Tuesday, August 23, 2011 9:00 AM


All replies

  • You did not give a lot details. I assume your OCX depends on at least one additional DLL. You could check this with the DependencyWalker (google for it and download it).

    Btw. is your issue a software developing issue or a general issue on registering an existing OCX?

    Tuesday, August 23, 2011 9:14 AM
  • It is a software development issue, creating an IE plugin.

    After compilation the .ocx file is generated, but I can't seem to register it, and can't find which required .dll is causing the problem. I'll try the DependencyWalker. Still, any ideas why this information doesn't show in the Event Viewer (on XP SP3)? thanks.


    Tuesday, August 23, 2011 10:03 AM
  • Have you tried to debug the application during registration? Have you downloaded the DependencyWalker and checked what DLLs are used by your OCX? You only need to open your OCX with DependencyWalker. You will see all DLLs needed by your OCX. In case you manually load DLLs by using LoadLibrary / GetProcAddress, you can also load the OCX using dependencyWalker and the programm will track all late loaded DLLs.
    Tuesday, August 23, 2011 10:55 AM
  • Still, any ideas why this information doesn't show in the Event Viewer (on XP SP3)? 

    Seems that this error message is considered harmless and does not correspond to any of Event's category - Error, Warning, Information - as described here:

    • Marked as answer by Rob Pan Monday, August 29, 2011 8:17 AM
    Tuesday, August 23, 2011 11:36 AM
  • I tried the DependencyWalker and it helped.

    Thanks, Hila



    Monday, August 29, 2011 8:23 AM