none
Core3.0 Class Library RRS feed

  • Question

  • How do you create a .NET Core class library in Visual Studio.

    I can create a WPF App or a WPF User Control Library but not a simple Class Library.

    I have to create a .NET Standard one and change the Csproj  file TargetFramework to netcoreapp3.0 but that seems a rather untidy way.


    John Meers

    Tuesday, November 5, 2019 6:50 PM

Answers

  • My 16.3.7 must have been corrupt.  As well as missing some templates it would not let me update to 16.3.8 and a repair on the core3 SDK failed as well.

    Cure was to completely uninstall VS and reinstall.  Seems OK now -  template is there.

    A bit of an odd fault,  but it also cleared out a lot of extensions etc that I had put in as trials so I have a nice clean install now.

    Thanks
        John


    John Meers

    • Marked as answer by JohnMeers Wednesday, November 6, 2019 2:04 PM
    Wednesday, November 6, 2019 2:04 PM

All replies

  • Hi JohnMeers,

    Welcome to MSDN forum.

    You could set the C# and library tag in visual studio, it will help you search it quickly.

    If it doesn't exist, please update your visual studio to update version, and check if .NET Core 3.0 SDK has been installed under "Individual components".

    In addition, you could also try to re-install .NET core 3.0 SDK , then check if it is created.

    Look forward to your feedback.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, November 6, 2019 1:51 AM
  • My 16.3.7 must have been corrupt.  As well as missing some templates it would not let me update to 16.3.8 and a repair on the core3 SDK failed as well.

    Cure was to completely uninstall VS and reinstall.  Seems OK now -  template is there.

    A bit of an odd fault,  but it also cleared out a lot of extensions etc that I had put in as trials so I have a nice clean install now.

    Thanks
        John


    John Meers

    • Marked as answer by JohnMeers Wednesday, November 6, 2019 2:04 PM
    Wednesday, November 6, 2019 2:04 PM