none
Enabling C++20 concepts in Community Edition RRS feed

  • Question

  • I have Community Edition preview 16.5.0 installed.  I don't seem to be able to used <concepts>

    Do I need to define anything, or install anything additional?

    Saturday, December 14, 2019 6:45 PM

All replies

  • Did you read this?

    C++20 Concepts Are Here in Visual Studio 2019 version 16.3
    https://devblogs.microsoft.com/cppblog/c20-concepts-are-here-in-visual-studio-2019-version-16-3/

    - Wayne

    Saturday, December 14, 2019 8:58 PM
  • The thing to remember here is that the intellisense still doesn't work with concepts.

    As you can see, I get the red squiggly lines under the concept related things but it compiles successfully. This is with the 16.5 preview too.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.

    Sunday, December 15, 2019 2:06 PM
  • Hello,

    If your issue is solved, please "Mark as answer" or "Vote as helpful" post to the appropriate answer , so that it will help other members to find solution quickly if they faces similar issue.

    Best Regards,

    Suarez Zhou


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 20, 2019 7:03 AM