Why did visual studio 2010 stop compiling files with an apostrophe in their filename?


  • Why did visual studio 2010 stop compiling files with an apostrophe in their filename?
    We have a few files in one of our Visual Studio projects that contain an apostrophe in their filenames. 
    We have been compiling those using Visual Studio 2010 projects for 12 years, at least 2 years using VS 2010.  The last successful build was done on March 15, 2012.
    Now Visual Studio is ignoring the custom build rule altogether for those files, as if they had been marked to exclude from build, which is NOT the case.
    I tried inserting an apostrophe into the filename of one of our .CPP files which uses regular C++ build rules and not a custom build rule and when that is done, I get an error message when a build is started:
         cl : Command line error D8003: missing source filename
    I have tried this on more than one PC and I get identical results.
    The only Microsoft update that was installed since the last successful build was the March 2012 one.

    Is there a fix available?

    Thursday, June 14, 2012 4:20 PM

All replies

  • Hi Quite,

    I found I could compiling files with an apostrophe in my computer. Are there something in your custom build command?

    From your error message show that you did not add file name to cl command.

    You can check your command and try it again.

    Best regards,


    Friday, June 15, 2012 8:46 AM
  • We were able to compile these files from when we started using VS2010 back in 2010 thru March 15, 2010.  After that, the March update from Microsoft was applied to that group of machines.  We only build that project a few times per year and it no longer builds unless the apostrophe's are removed, which is not an option for us as our application requires the file names to match the data contained within the files which has to have the apostrophe.  It's not in the custom build rule as the custom build rule is not invoked any longer.  It is somewhere in Visual Studio prior to the invocation of the custom build rule.

    J Balster

    Friday, June 15, 2012 3:59 PM
  • Hi Quite Good 001,

    I tried creating a project as you said in my computer, it could be compiled well. I used Visual Studio 2010.

    I think you can restores Visual Studio default settings and try again.

    If it can not work either, you can submit your issue to

    Best regards,


    Tuesday, June 19, 2012 7:15 AM
  • I looked at and it says to only use it to report problems in VS2012.  I am using VS2010.  This was not a problem in VS2010 all of the prior times I build our application.  It used to compile.  The last successful build using VS2010 was in mid March 2012.  The fact that someone else can build with an apostrophe in a filename does not say whether or not they have installed the same update(s).

    J Balster

    Monday, June 25, 2012 6:36 PM
  • Hi J,

    Can you list the update which you think caused your issue? Remove it and try again.

    I also tried in my Visual Studio 2010, it could not be reproduced.

    Maybe you can use Visual Studio Setup Wizard (via Control Panel) to repair Visual Studio. It can restore the Visual Studio Installation into its original state.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, June 26, 2012 8:07 AM