none
Unable to load data on website RRS feed

  • Question

  • I'm getting a red x with the notation" unable to load data, please check your network connection and try again'  The data for the table is being pulled from a SQL database on a seperate server.  It works fine during debugging on the dev server but is failing to load from the actuall website. What is the best way to determine what the roadblock is? I'm pretty much a newbee at lightswitch and at deploying websites.

    Tuesday, December 20, 2011 3:59 PM

Answers

All replies

    • Marked as answer by BCooperider Wednesday, December 21, 2011 1:03 PM
    Tuesday, December 20, 2011 4:03 PM
  • Thanks, going to work on getting the tracing set up, ports should be good but who knows, also I'm on a 2003 server, looks like tracing is easy to set up on 2008, hopefully I can make sense of it on the 2003 box, thanks again.
    Tuesday, December 20, 2011 4:25 PM
  • The trace was helpful in determining what the issue is.

    System.Data.EntityException: The underlying provider failed on Open. ---> System.Data.SqlClient.SqlException: Login failed for user

    Trying to determine where it pulls that username from, is that from the apppool identity on the webserver? Then need to determin where I need to change, or add that username to enable the login to succeed.

    Tuesday, December 20, 2011 6:18 PM
  • That looks like the user in the connection string in web.config.  The username and/or password is not right or not configured for access on the sql db. When you deploy the app there is two places for ids. First is sql admin user so that your client can create the db. The other is for user access which is the connection string used on open during normal usage.
    • Proposed as answer by Yann DuranModerator Wednesday, December 21, 2011 12:13 AM
    • Marked as answer by BCooperider Wednesday, December 21, 2011 1:03 PM
    Tuesday, December 20, 2011 7:15 PM
  • Thanks, that gave me the idea of just changing the connection string in the config to match whats working for other applications and it works. Appreciate the reply. Now I can concentrate on design improvements.
    Wednesday, December 21, 2011 12:57 AM
  • Great. Please mark as answered which helps forum.
    Wednesday, December 21, 2011 8:52 AM