none
VS 2017: System.ExecutionEngineException

    Question

  • Hello all,

    Yesterday, I started getting the following error when I run my program: System.ExecutionEngineException:'type of exception 'System.ExecutionEngineException' actioned'. This happened in one pc of mine, and today I worked with another one (since I thought it was cause by updating Windows...). With this other pc it worked perfectly, until I turned it off, turned it on again, and tried running it again.... this error started again!

    I have tried the solution 'Disabling the "Enable Diagnostic Tools while debugging" and "Show elapsed time PerfTip while debugging" in the Tools > Options > Debugging" but it doesn't work.

    Also, one of the times the following message error appeared: "Exception found. This can be caused by an exception. To obtain further information, examine the file "C:\\Users\Diogo Tecelão\AppData\Roaming\Microsoft\VisualStudio\15.0_f14199d6\ActivityLog.xml'.

    You can find the dumpfile here: https://ufile.io/2n348

    Please, help! I need to work with VS asap!

    Thank you for your time,

    Diogo

    Thursday, December 07, 2017 7:39 PM

All replies

  • Some lines of code where this is showing... I've been working with this code for about one week and I never had any problem: https://imgur.com/a/J78CW and https://imgur.com/a/eRE74


    Thursday, December 07, 2017 7:46 PM
  • Hi Diogo,

    Not sure if the issue is caused by VS IDE, if this only happens to VS 2017, then what's the specific update of VS2017 in your side? The latest one is VS2017 15.5.0, you may update it to see if it's been fixed.

    Another potential workaround could be:

    Delete the contents of the temp folder (usually located at C:\Users\<user>\AppData\Local\Temp ) and re-start Visual Studio.

    Please let us know if above could work.

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, December 08, 2017 7:35 AM
  • Hello Fletcher, 

    Thank you for your reply.

    Unfortunately it didn't worked. I also tried reinstalling my VS and the problem persists.

    Also, a collegue of mine who is also working on the project is having the same issue. Could the problem be in the project? I'm sending you the project so you can inspect: https://ufile.io/8y5ng

    When I try running a (not so) old version of the project, the problem goes away..

    Thank you for your time


    Friday, December 08, 2017 5:43 PM
  • Please run VS in safe mode to check if it's caused some extensions. 

    Based on your description this issue is more related to project itself other than VS IDE.

    I could  notdownload the file from third party Cloud, you may upload it to OneDrive, and share us the download link, please compress file with .zip if it's possible.

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Monday, December 11, 2017 9:43 AM