none
TestController in workgroup is unavailable for Test Controller Manager RRS feed

  • Question

  • Hello!

    I'm trying setup TestController for the following topology:

    Workgroup:

    - Test Controller

    - Test Agent

    Domain:

    - TFS

    - MTM

    It seemed that everything was set up correctly:

    - The controller is registered in TFS

    - The controller is running

    But in Test Manager, my controller is marked as unavailable, and we can not set up an environment using the controller. If I run the agent on the same machine as the controller, it is configured correctly and see the controller. But from domain machine, I can't configured Agent with this Controller. 

    Maybe the reason is that we use a local administrator account (. \ Administrator) to start the service TestController? 

    What should I do to make it work?
    • Edited by ALD110 Wednesday, October 8, 2014 1:16 PM
    Wednesday, October 8, 2014 12:10 PM

Answers

  • Hi,

    In order to resolve your issue, please create a local user account with the same user name and password on both the MTM machine and the test controller machine.

    In addition, your lab environment matches Workgroup topology described in this document: Setting Up Test Controllers in Lab Environments, we recommend to configure the lab service account with alternate credentials on your test controller.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, October 9, 2014 6:23 AM
    Moderator