none
I am trying to debug my project on Visual Studio RRS feed

  • Question

  • I am trying to debug my project on Visual studio 17&19 with Core I7 8th gen with Asus prime 370m plus , It got crashed at every time , I tried a lot of troubleshooting but still same situation , please suggest me if it would hardware issue then we have purched a lot of system ,so it would difficuult for me to change all systems.
    Monday, November 18, 2019 9:22 AM

All replies

  • Memory used by Visual studio got increased frequently and after approx 4 GB ram utilization by VS , it got crashed.I have tried it on 4-5 same systems , but got the same things on all machines.

    VS fullu updated with latest patch and license

    Win 10 - 1909 fullu updated with latest patch and license

    Monday, November 18, 2019 9:29 AM
  • What language did you write your project in?
    Monday, November 18, 2019 9:47 AM
  • Hi Ganesh Pratap Singh,

    Welcome to MSDN forum.

    According to your description, which kind of project do you use? Do you use other third-party plugins/extensions or software?

    Not sure what troubleshooting do you try, I share you with below suggestions to troubleshoot this issue and please check if your issue could be solved.

    (1) Please open Visual Studio and go to Debug -> Options -> General -> uncheck “Enable Diagnostic Tools while debugging” checkbox -> OK

    (2) Try to start VS in safe mode from Developer Command Prompt for VS 2019 -> enter devenv /safemode and debug again to check if your issue could be solved.

    (3) If possible, you could try to create a new project and start debugging to see if debug could work well this time. This will be helpful to determine if this issue is caused by VS or the project.

    (4) If you use “Start Without Debugging” could your project be built and work well without getting any error message?

    (5) I could not determine this issue is caused by hardware, since you said you got the same things on all machines, I suppose it might be more related to your project or the VS IDE, or maybe the confliction of other running applications or plugins.

    (6) Not sure if repair VS could fix this issue, but maybe you could have a try. (Visual Studio Installer -> find Visual Studio 2019 -> More -> Repair)

    In addition, does Visual Studio provide you with some error message? If possible, could you share them with us.

    Any feedback will be expected.

    Best Regards,

    Tianyu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Tuesday, November 19, 2019 6:21 AM
  • Hi Ganesh Pratap Singh,

    Sorry for bothering you.

    As far as I know, the amount of virtual memory available to Visual Studio is 4 GB. Please refer here:Use a 64-bit OS

    Is your project too big to use multiple memories? If so, we recommend you could try to accelerate your memory, then see if it could work.

    If not, please follow MSND doc:Visual Studio performance tips and tricks, to configure your running environment, then re-debug your project.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, November 22, 2019 10:00 AM