none
Test plan disappear from MTM after insert RRS feed

  • Question

  • Hi,

    I have an issue with a user that has been designed as test manager in my team. The user can correctly create a plan by MTM, but when he tries to open it he receives the error:

    "The test plan has been removed: The test plan you tried to connect to has been removed, please select another plan to connect to"

    If he quit and enter the list of plans is empty. The plan exists but he don't see it in MTM and in web access tool too. I can see it  (I'm team administrator).

    I ensured the user has view test runs  permission(he also has the "create test runs" and  "delete test runs"). I also ensured that the user has the"manage test plans" permission in the area security  tab (I set it at the root level of area tree).

    Further details:  TFSServer version: 2012 Update 3 ( 11.0.60610.1)

    I'm quite sure it's a permissions issue. Is there some log to check or some command line (like tfspsecurity) I can launch to check my system?

    Any help would be  appreciated....Thank you very much

    Federico

    Monday, September 9, 2013 10:11 AM

Answers

All replies

  • Hi Federico,

    Thanks for your post!

    According to your description, firstly I think the error that you get that may due to the user’s permission has been modified.

    Secondly, as you said “I also ensured that the user has the"manage test plans" permission in the area security tab (I set it at the root level of area tree).”, as far as I know that the user can’t view or manage the test plan if he has not permission for its Area or Iteration regardless of he has the permission in root level.

    So I suggest that you should check the permission of that plan’s Area and Iteration. You can find that plan’s properties of Area and Iteration in the MTM.

    Thanks

    Best Regards


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Tuesday, September 10, 2013 5:38 AM
    Moderator
  • Hi Starain,

    Thank you very much for your reply. Here I attach ascreenshot, just to better explain what I mean about giving permissions at the root level:

    However I tried in several ways to change area of the test plan, or giving explicit permissions for a child, but with no luck.

    In your reply you talk about Iteration permissions. I went In the iteration tab, clicking on security for a given iteration and I see options like:

    "create child nodes", "delete this node", "edit this node" , "view permissions for this node", do I have to give this kind of permissions to m test manager?

    Tuesday, September 10, 2013 7:59 AM
  • Hi Federico,

    If you explicitly set View Permissions for this node to Deny of the area path which you use in the test plan for that user, the user can't view test plans or work items in that area path. The same as iteration.

    For your current situation, please first figure out which area and iteration that test plan is in. Then check the specific area and path to make sure you explicitly set allow permissions for that user.

    Thanks,


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Wednesday, September 11, 2013 3:52 AM
  • Hi Vicky,

    I didn't set any deny permissions in child areas. In my first try I didn't set any permission at all to child areas, just the one at root level. Lately, I tried to set explicit allow to specific child areas associated with test plans created by my user, but with no luck. My user continues to create test plans that disappear to his view after creation....

    What about Iteration permissions? Do I have to set permissions at iteration level? Which kind of permissions?

    Do I have any tool that can help me to better understand the issue?

    Thanks

    Federico

    Wednesday, September 11, 2013 12:48 PM
  • Hi Federico, I just had the same problem for this issue. You must set the Area\View permissions for this node to ALLOW. Then it will work.  See this URL also: http://connect.microsoft.com/VisualStudio/feedback/details/781563/cannot-select-a-test-plan-in-mtm-unless-you-have-view-permissions-for-this-node-area-permission

    ALLOW View Permissions

    Wednesday, September 11, 2013 7:12 PM
  • Hi Federico,

    For Iteration permssions, you need to View Permissions for this node to Allow for that iteration that the test plan in.

    Thanks.


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Thursday, September 12, 2013 2:01 AM
  • Thanks a lot Reboots! You saved my life

    It worked

    I don't know if this a bug or  just a bad choice in naming, but I really hope in 2013 version there will be a different behavior !!!

    Friday, September 13, 2013 7:37 AM
  • I think it truly was a naming problem. Glad to have helped!
    Friday, September 13, 2013 2:38 PM