none
.Net Framework 4 CLR20r3 Error RRS feed

  • Question

  • I'm using VS 2010 and .Net Framework 4

    I developed an app, created and installer and installed it on another computer. The app doesn't start on that computer.

    By checking the event log I found this:

     

    Application: Sports Tracker.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.InvalidOperationException Stack: at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel() at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[) at WindowsApplication1.My.MyApplication.Main(System.String[)

    and this:

    Sports Tracker.exe 
    1.0.0.0 
    4f2bf2f4 
    KERNELBASE.dll 
    6.1.7600.16850 
    4e211485 
    e0434352 
    0000b9bc 
    1114 
    01cce29b07be5a50 
    C:\Program Files (x86)\TGS\Sports Tracker\Sports Tracker.exe 
    C:\Windows\syswow64\KERNELBASE.dll 
    
    4650f051-4e8e-11e1-9197-00238bf5b722[/CODE]
    

    and this:

    2750355915 
    5 
    CLR20r3 
    Not available
    0 
    sports tracker.exe 
    1.0.0.0 
    4f2bf2f4 
    Sports Tracker 
    1.0.0.0 
    4f2bf2f4 
    f 
    e9 
    System.InvalidOperationException 
    
    C:\Users\Rafael\AppData\Local\Temp\WER2F4E.tmp.WERInternalMetadata.xml 
    C:\Users\Rafael\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_sports tracker.e_791ba3451e349516de2163964ba4d2ea7d13b81_0dd73b7e 
    
    0 
    4650f051-4e8e-11e1-9197-00238bf5b722 
    0

    How to solve this?

    Saturday, February 4, 2012 12:43 AM

Answers

All replies

  • You need to verify the integrity of the .NET Framework 4.0 installation on the target machine.

    Use this tool:

    http://social.msdn.microsoft.com/Search/en-US?query=.net%20framework%20verification%20tool&beta=0&ac=1

    Post the first 15 lines and last 15 lines of tool output here.

    Saturday, February 4, 2012 1:56 AM
  • Hi TechMaiden,

    Welcome to the MSDN forum.

    First please verify the integrity of the .NET Framework 4.0 installation your target machine. If the verification of .NET Framewrok fails. You should uninstall .NET Framework 4 from that machine and install it with a stand-alone package from http://www.microsoft.com/download/en/details.aspx?id=17718 .

    If it verifies as well. You need to post your question to http://social.msdn.microsoft.com/Forums/en-US/winformssetup/threads.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, February 9, 2012 9:22 AM
    Moderator
  • IMO, the CLR2.0r3 could also mean there is/are bugs in your app. The bugs might be not caught by try catch block construct.  That is, your app crahsed.  I've encountered this event log error several times.  By exmine my buggy app, when I fix the bugs, the clr20r3 disappeared automatically.  Just try to narrow down the scope of your possible bugs that cause your app to crash.  You can by just guessing the most likely part of buggy codes or else step by step through your code.

    My blog: http://soho-hsh.blogspot.com

    Wednesday, February 15, 2012 11:02 AM
  • I had a similar issue with my windows form app crashing immediately upon loading with the same "CLR20r3 " error.  So I added a new form, set that new form as the start up form and gave it just a single button that loaded my original start-up form and rebuilt the exe. When I ran that version on my x64 server the startup form loaded fine and I didn't get an error until I clicked on the button to load my original form.  HOWEVER this time because the app was already running I got much more useful error information - in my case the error was "could not load file or assembly 'Microsoft.VisualBasic.PowerPacks'"

    Hope this troubleshooting method helps someone. Yes its a bit of a crude method but I was in a hurry and it was quick and worked.

    To summarise - I added a new blank form to my app, set that form as the start up form and gave it a single button that launched my original startup form. Apart from that button and its single line of code "mainform.Show()"  I did not modify that form after adding it to the project. This allowed me to get the app running before triggering the error so that the error was reported with more detail.

    Thursday, July 26, 2012 10:48 AM
  • I too had the problem,  upon checking the even viewer where it is clearly written that Configuration Manager exception in not Handled, this is many times the corrupted users configuration.

    i log in  as another user, the application is working.

    kindly can experts throw some light on it. why user profile gets corrupt and how to repair it in windows 7

    Saturday, July 28, 2012 10:53 AM
  • Great idea! Worked for me.  I've been fighting with this error for over a day trying figure out what my app was looking for on my new computer.  Thanks!
    Saturday, November 4, 2017 4:02 PM