locked
VS2012 Fatal Error Install RRS feed

  • Question

  • I'm running in Windows 8, and I run the setup file vs_professional.exe as administrator.  How can I give the priveleges?

    Thanks in advance.

    From the log file:

    [0FDC:20E4][2014-11-26T08:09:33]: MUX:  ExecuteError: Package (vs_professionalcoreres) failed: Error Message Id: 1321 ErrorMessage: Error 1321.The Installer has insufficient privileges to modify this file: C:\WINDOWS\SysWOW64\1033\vsjitdebuggerui.dll.

    Wednesday, November 26, 2014 2:22 PM

Answers

  • Hi Charles Stangor,

    I have found the vsjitdebuggerui.dll file in my PC. I paste its properties below for your compare.

    (my screenshot here) We can see that permissions for “read” and “read & execute” are allow. Please check them in your side.

    If yours is the same as me, please temporarily turn off anti-virus and reinstall. Because your antivirus or security software may be conflicting with or blocking VS installation.

    If not, in other words, Windows permissions for the file are set to restrict access, please try to give permission to that file again. I see that you can’t do that because you don’t have read permissions to view the properties of the object. In such cases you need to Take Ownership of the file or folder. To do so click on “Advanced”. Next, in the windows that appears, you have to click on “Change” and enter the object name. You can read “How to Take Ownership on Windows 8” section in this article http://www.thewindowsclub.com/take-ownership-windows-8

    What’s more, I suggest you installing another software on your PC to check if you can install it successfully to isolate your system file issue.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Anna Cc Tuesday, December 9, 2014 8:37 AM
    Thursday, December 4, 2014 9:38 AM

All replies

  • Using an admin account, locate the file in File Explorer, then right-click and select Properties from the context menu. Select the Security tab, then apply Write permissions.
    Wednesday, November 26, 2014 4:31 PM
  • Hi Charles Stangor,

    According to the error log, the issue is that the Installer has insufficient privileges to modify this file vsjitdebuggerui.dll.

    Please refer to the similar thread:https://social.msdn.microsoft.com/Forums/en-US/02af7bac-0eae-45bb-9913-e181c6030e10/fatal-error-during-uninstallation-of-visual-studio-2012-professional?forum=vssetup

    First Download subinacl tool from the below link

    http://www.microsoft.com/en-in/download/details.aspx?id=23510

    and execute the below line the commandprompt with admin privillages.

    subinacl /subdirectories %programdata%\*.* /grant=administrators=f /grant=system=f

    At last, run the setup to see if it works fine.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, November 27, 2014 6:14 AM
  • Thanks so much for the quick replies!

    So I downloaded and ran the subinacl program as suggested.  It appears to change over 8000 files without errors, but I still get the same access error when I try to install.

    I cannot seem to change the permissions on the file that creates the problem:

    When I open the securities tab in the properties dialogue I get "You must have read permissions to view the properties of this object."

    When I go to "Advanced" from there I get:

    "You do not have permission to view this object's security properties, even as administrative user."

    Ouch!

    Thanks again.

    Thursday, November 27, 2014 3:03 PM
  • Hi Charles Stangor,

    I have found the vsjitdebuggerui.dll file in my PC. I paste its properties below for your compare.

    (my screenshot here) We can see that permissions for “read” and “read & execute” are allow. Please check them in your side.

    If yours is the same as me, please temporarily turn off anti-virus and reinstall. Because your antivirus or security software may be conflicting with or blocking VS installation.

    If not, in other words, Windows permissions for the file are set to restrict access, please try to give permission to that file again. I see that you can’t do that because you don’t have read permissions to view the properties of the object. In such cases you need to Take Ownership of the file or folder. To do so click on “Advanced”. Next, in the windows that appears, you have to click on “Change” and enter the object name. You can read “How to Take Ownership on Windows 8” section in this article http://www.thewindowsclub.com/take-ownership-windows-8

    What’s more, I suggest you installing another software on your PC to check if you can install it successfully to isolate your system file issue.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Anna Cc Tuesday, December 9, 2014 8:37 AM
    Thursday, December 4, 2014 9:38 AM
  • I had this exact problem and fixed it by renaming the C:\WINDOWS\SysWOW64\1033 folder. That folder had no owner and no permissions set on my machine and I kept getting errors while trying to change them.
    • Proposed as answer by CarlinScott Saturday, November 14, 2015 12:17 AM
    Saturday, November 14, 2015 12:17 AM