Error TF248001 when uploading process template


  • I have a work item type in my process template that is setup like this:

    <FIELD name="Project Name" refname="MyCompany.Common.ProjectName" type="String">
            <READONLY not="[project]\Project Administrators" />

    But when I try to upload the process template the get the following error in the log:

    Exception Message: TF248001: You have specified a project-scoped group, '[project]\Project Administrators', which is not allowed for a global list or a global workflow that is defined for a project collection. Remove the reference to the specified group. (type ProvisionValidationException)

    My field is not a global list or part of a global workflow, so I'm not sure why I'm getting this error. If I remove the READONLY field the process template uploads just fine. But, I can load that specific work item type manually without any problems into a team project.

    Any idea why it's a problem loading when done as part of the process template upload?

    This is for TFS2010.


    Monday, October 01, 2012 3:09 PM


All replies

  • Hi Anthony,

    Thank you for your post.

    I test the issue in my side, i add a field as same as your post in a process template, the result is i can save the process template and upload it to TFS server. Also, i can create new team project with that process template.

    Hope you can provide following information to help narrow down the issue:
    The detail steps you do to the process template. Include, which WIT you add the field to? How do you add that field, edit the existing field, or create a new WIT?



    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, October 02, 2012 2:47 AM
  • I'm working with the Sprint WIT from the Scrum template. I have used the Process Editor from the Power Tools to make the change. I then export the WIT and add it to my process template. When I export it, I don't save the global lists.

    I'll try making the change manually to the xml file.

    Tuesday, October 02, 2012 12:46 PM
  • Hi Anthony,

    you need to install TFS SP1. One of the issues fixed is this:

    • The process template is not uploaded if a work item type definition references project level groups.

    You can find more info and download link here:

    Transcendent Group

    Tuesday, October 02, 2012 12:51 PM
  • I've installed SP1. I'll try again. Thanks.
    Tuesday, October 02, 2012 12:54 PM
  • That was it. I must have missed it somehow. 

    Thanks, my process template uploads just fine.

    Tuesday, October 02, 2012 3:37 PM
  • Hi Anthony,

    I have pretty much run into the same problem and it just does not seems to go away with the SP1 (which I already have). I am basically restricting the values in certain fields using groups 

    <FIELD name="Assigned To" refname="System.AssignedTo" type="String" syncnamechanges="true">
            <ALLOWEDVALUES filteritems="excludegroups">
              <LISTITEM value="[Project]\People" />
            <HELPTEXT>The person currently working on this story</HELPTEXT>

    Unfortunately, I can't avoid having restrictions using groups. Any ideas?


    Wednesday, October 17, 2012 8:31 AM
  • Just to verify, it is TFS SP1 that you have applied correct and not VS2010 SP1?

    Once I applied TFS SP1 it worked just fine.


    Wednesday, October 17, 2012 12:25 PM
  • Hi Anthony,

    Its the TFS SP1.


    Wednesday, October 17, 2012 12:30 PM
  • Hello

    I have the same problem even after TFS SP1. My list is defined as

    <FIELD name="Assigned To" refname="System.AssignedTo" type="String" syncnamechanges="true" reportable="dimension">
            <HELPTEXT>The person currently working on this bug (Uses team defined values)</HELPTEXT>
            <!-- if {USER_RULES} -->
            <ALLOWEDVALUES expanditems="true" filteritems="excludegroups"><LISTITEM value="[project]\Contributors" /></ALLOWEDVALUES>
            <!-- endif {USER_RULES} -->

    It fails with the TF248001 error saying that "You have specified a project-scoped group, '[project]\Contributors', which is not allowed for a global list or a global workflow that is defined for a project collection.".

    I did apply TFS SP1 .

    Any suggestions?



    Wednesday, December 05, 2012 8:01 PM
  • Hi Prakash,

    The key here is to use global keyword instead of project or collection. I used  [GLOBAL]\People instead of [PROJECT]\People which worked for me.


    Try using  [GLOBAL]\CONTRIBUTORS. It should work.


    Paritosh Arya

    • Proposed as answer by Paritosh Arya Thursday, December 06, 2012 9:07 AM
    • Unproposed as answer by Paritosh Arya Thursday, December 06, 2012 9:07 AM
    Thursday, December 06, 2012 9:06 AM
  • Thx for the reply Arya. I am new to TFS. But, our contributors list is unique for each project.  If I use [Global], wouldn't all the contributors from all projects show up?




    Thursday, December 06, 2012 1:37 PM
  • If your project is in different collection this will work, but if all project reside under same collection, you will have problems.

    You can refer to this link

    Thursday, December 06, 2012 1:56 PM