none
iis problem when try to publish web app with asp.net core 2.2 ? RRS feed

  • Question

  • Problem

    iis problem when try to publish web app with asp.net core 2.2 ?

    when i want to publish web app working on dot net core
    asp.net core 2.2 I get server error :

    Application 'MACHINE/WEBROOT/APPHOST/TABBACKEND' with physical root 'D:\WebModule\BackEnd\' failed to start process with commandline 'dotnet .\FormFunctions.dll', ErrorCode = '0x80070002' : 0.

    on event log viewer

    How to solve this problem ?

    What I have tried:

    I already installed .net core 2.2.7 run time and already run on server

    Thursday, October 24, 2019 12:50 AM

Answers

  • Hi engahmedbarbary,

    Thank you for feedback.

    Please have a try to go to application pool -> advance setting -> change "Identity" to "Local system". It may be caused by access permission.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, October 28, 2019 10:16 AM

All replies

  • Hi engahmedbarbary,

    Welcome to MSDN forum.

    For this error, it maybe cannot find the dotnet tool on your local machine, we recommend you could go to web config file, then change the processpath to full directory. And you could refer the similar issue.

    processPath="C:\Program Files\dotnet\dotnet.exe"

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, October 24, 2019 10:16 AM
  • thank you for reply 

    i do as above but  error still exist 

    Saturday, October 26, 2019 11:46 AM
  • Hi engahmedbarbary,

    Thank you for feedback.

    Please have a try to go to application pool -> advance setting -> change "Identity" to "Local system". It may be caused by access permission.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, October 28, 2019 10:16 AM